summaryrefslogtreecommitdiff
path: root/x11-themes/tela-icon-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /x11-themes/tela-icon-theme
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'x11-themes/tela-icon-theme')
-rw-r--r--x11-themes/tela-icon-theme/Manifest4
-rw-r--r--x11-themes/tela-icon-theme/metadata.xml30
-rw-r--r--x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild67
-rw-r--r--x11-themes/tela-icon-theme/tela-icon-theme-99999999.ebuild68
4 files changed, 169 insertions, 0 deletions
diff --git a/x11-themes/tela-icon-theme/Manifest b/x11-themes/tela-icon-theme/Manifest
new file mode 100644
index 000000000000..131d29daf144
--- /dev/null
+++ b/x11-themes/tela-icon-theme/Manifest
@@ -0,0 +1,4 @@
+DIST tela-icon-theme-20211225.tar.gz 3592063 BLAKE2B d5b16f4f3899fc162082d2ee2432367e4b81527e71d1689c1f9f930bb22a799485d3b127f9aafa803b3356ad462e59cd5e78ae17fdd7607edf68794307c0c8d8 SHA512 4b4db7c07e4349879dd6568b0cd06476027cef173565bb91fe89909cf1d6bbad591c6b9ce29c81bef03f71211fc06d71da353e9116103b8407b0fb3141e0d949
+EBUILD tela-icon-theme-20211225.ebuild 1774 BLAKE2B c79c8a6b5c39e35bec037963feee39589eee1ccf9ea2a2e5adccc282b8d7c16cf609a33c160edcf702f27f0f9c0e9e60b49663a3ea909612210479be7422af86 SHA512 1ab539eb6e6b5e5344ac802c3919db2d8b717dfb86e9be309ac0811560ae12019d1abb7f2e9d70a530c7d68b0ce6acd1b8cdc4d7ac8e4e267bc4567205a1bfef
+EBUILD tela-icon-theme-99999999.ebuild 1797 BLAKE2B 1ec658013b38a58483ec57e4da231487ad38f6649c7b373e8e3c5c1288c069aaddb0d199bd13a963a85af0657a82e0e85d8ded41fb709906ebe1933449928aed SHA512 0383df25111068a5a09495589d9bbc002ce3c454860a345c85c1a03b1a5ed7819217d91bb6e9244644a12b9d1ad9a0816c9f4e6c132ac9037f31ac5203ca4bd0
+MISC metadata.xml 1405 BLAKE2B 164dd20ae30cda4ae2886e9770ddb92e2f68b4a6644b010112d647434735a8bc204ac90bf00b5d6efcf63eef05d90eb9191929de6a74ee0d786970478beaaf04 SHA512 745c72aca306d7df013616a0e70b564d54e89cc88c69c8e0dddc15e8c07a6ca9896d05a81e40dffb04b79f3be01c82fc495daf4947473912246986024afce20e
diff --git a/x11-themes/tela-icon-theme/metadata.xml b/x11-themes/tela-icon-theme/metadata.xml
new file mode 100644
index 000000000000..11f07ab3afc3
--- /dev/null
+++ b/x11-themes/tela-icon-theme/metadata.xml
@@ -0,0 +1,30 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <use>
+ <flag name="standard">Install standard folder version</flag>
+ <flag name="black">Install black folder version</flag>
+ <flag name="blue">Install blue folder version</flag>
+ <flag name="brown">Install bworn folder version</flag>
+ <flag name="green">Install green folder version</flag>
+ <flag name="grey">Install grey folder version</flag>
+ <flag name="orange">Install orange folder version</flag>
+ <flag name="pink">Install pink folder version</flag>
+ <flag name="purple">Install purple folder version</flag>
+ <flag name="red">Install red older version</flag>
+ <flag name="yellow">Install yellow folder version</flag>
+ <flag name="manjaro">Install manjaro folder version</flag>
+ <flag name="ubuntu">Install ubuntu folder version</flag>
+ <flag name="kde">Install colorshceme version for KDE plasma (folder color follow the colorscheme)</flag>
+ <flag name="hardlink">Hardlink duplicate icons to greatly reduce installation size</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://github.com/vinceliuice/Tela-icon-theme/issues</bugs-to>
+ <remote-id type="github">vinceliuice/Tela-icon-theme</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild b/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
new file mode 100644
index 000000000000..4a7dbec99539
--- /dev/null
+++ b/x11-themes/tela-icon-theme/tela-icon-theme-20211225.ebuild
@@ -0,0 +1,67 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# eg. 20211225 -> 2021-12-25
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="${PN^}"
+
+# standard comes first
+MY_COLOR_VARIANTS=( standard black blue brown green grey orange pink purple red yellow manjaro ubuntu )
+
+inherit xdg
+
+DESCRIPTION="A flat colorful Design icon theme"
+HOMEPAGE="https://github.com/vinceliuice/Tela-icon-theme"
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+${MY_COLOR_VARIANTS[*]} +hardlink" # this is why standard comes first
+
+REQUIRED_USE="|| ( ${MY_COLOR_VARIANTS[*]} )"
+
+# not needed and slows us down, package installs 120 000 small files
+RESTRICT="binchecks strip test"
+
+# technically we can use app-arch/harlink too, but it's deprecated
+BDEPEND="
+ app-shells/bash
+ sys-apps/util-linux[hardlink(-)?]
+"
+
+src_prepare() {
+ default
+ # we use eclass for that
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ local v variants=(
+ $(for v in ${MY_COLOR_VARIANTS[@]}; do
+ usev ${v}
+ done)
+ )
+
+ dodir /usr/share/icons
+ ./install.sh -d "${ED}/usr/share/icons" "${variants[@]}" || die
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ # https://bugs.gentoo.org/830467
+ find "${ED}" -xtype l -name uav.svg -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}
diff --git a/x11-themes/tela-icon-theme/tela-icon-theme-99999999.ebuild b/x11-themes/tela-icon-theme/tela-icon-theme-99999999.ebuild
new file mode 100644
index 000000000000..8396dac63033
--- /dev/null
+++ b/x11-themes/tela-icon-theme/tela-icon-theme-99999999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# eg. 20211225 -> 2021-12-25
+MY_PV="${PV:0:4}-${PV:4:2}-${PV:6:2}"
+MY_PN="${PN^}"
+
+# standard comes first
+MY_COLOR_VARIANTS=( standard black blue brown green grey orange pink purple red yellow manjaro ubuntu )
+
+inherit xdg
+
+DESCRIPTION="A flat colorful Design icon theme"
+HOMEPAGE="https://github.com/vinceliuice/Tela-icon-theme"
+
+if [[ ${PV} == 99999999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+${MY_COLOR_VARIANTS[*]} +hardlink kde" # this is why standard comes first
+
+REQUIRED_USE="|| ( ${MY_COLOR_VARIANTS[*]} )"
+
+# not needed and slows us down, package installs 120 000 small files
+RESTRICT="binchecks strip test"
+
+# technically we can use app-arch/harlink too, but it's deprecated
+BDEPEND="
+ app-shells/bash
+ sys-apps/util-linux[hardlink(-)?]
+"
+
+src_prepare() {
+ default
+ # we use eclass for that
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ local v variants=(
+ $(usev kde '-c')
+ $(for v in ${MY_COLOR_VARIANTS[@]}; do
+ usev ${v}
+ done)
+ )
+
+ dodir /usr/share/icons
+ ./install.sh -d "${ED}/usr/share/icons" "${variants[@]}" || die
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ # https://bugs.gentoo.org/830467
+ find "${ED}" -xtype l -name uav.svg -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}