summaryrefslogtreecommitdiff
path: root/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild')
-rw-r--r--x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
new file mode 100644
index 000000000000..f0817a298cb5
--- /dev/null
+++ b/x11-themes/leonidas-backgrounds/leonidas-backgrounds-11.0.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=12
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F11_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="!x11-themes/fedora-backgrounds:11"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+
+src_unpack() {
+ rpm_src_unpack
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ dodoc Credits
+
+ insinto /usr/share/backgrounds/leonidas
+ doins -r leonidas* landscape lion
+
+ insinto /usr/share/gnome-background-properties
+ doins desktop-*.xml
+}