summaryrefslogtreecommitdiff
path: root/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild')
-rw-r--r--x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild b/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild
new file mode 100644
index 000000000000..711e7ea18b9e
--- /dev/null
+++ b/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit rpm
+
+MY_P="${PN}-$(ver_cut 1-3)"
+
+DESCRIPTION="Fedora 14 official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F14_Artwork"
+SRC_URI="https://archives.fedoraproject.org/pub/archive/fedora/linux/development/15/source/SRPMS/${PN}-$(ver_rs 3 -).fc15.src.rpm"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="CC-BY-SA-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2017-07-28 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install
+}