summaryrefslogtreecommitdiff
path: root/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild')
-rw-r--r--x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild b/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild
new file mode 100644
index 000000000000..c8339b631c36
--- /dev/null
+++ b/x11-themes/laughlin-backgrounds/laughlin-backgrounds-14.1.0.3-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator rpm
+
+SRC_PATH=development/15/source/SRPMS
+FEDORA=15
+
+MY_P="${PN}-$(get_version_component_range 1-3)"
+
+DESCRIPTION="Fedora official background artwork"
+HOMEPAGE="https://fedoraproject.org/wiki/F14_Artwork"
+
+SRC_URI="mirror://fedora-dev/${SRC_PATH}/${PN}-$(replace_version_separator 3 -).fc${FEDORA}.src.rpm"
+
+LICENSE="CC-BY-SA-2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+SLOT=0
+
+src_unpack() {
+ rpm_src_unpack
+
+ # as of 2017-07-28 rpm.eclass does not unpack the further lzma
+ # file automatically.
+ unpack ./${MY_P}.tar.lzma
+}
+
+src_compile() { :; }
+src_test() { :; }
+
+src_install() {
+ # The install targets are serial anyway.
+ emake -j1 DESTDIR="${D}" install || die "emake install failed"
+}