summaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild')
-rw-r--r--x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
new file mode 100644
index 000000000000..94c86304a7f1
--- /dev/null
+++ b/x11-themes/gtk-engines-ubuntulooks/gtk-engines-ubuntulooks-0.9.12-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit autotools eutils
+
+PATCH_LEVEL=12
+MY_PN=${PN/gtk-engines-}
+
+DESCRIPTION="A derivative of the standard Clearlooks GTK+ 2.x engine with more orange feel"
+HOMEPAGE="http://packages.ubuntu.com/search?keywords=gtk2-engines-ubuntulooks"
+SRC_URI="mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz
+ mirror://ubuntu/pool/main/u/${MY_PN}/${MY_PN}_${PV}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_PN}_${PV}-${PATCH_LEVEL}.diff
+ EPATCH_FORCE=yes EPATCH_SUFFIX=patch epatch debian/patches
+ epatch "${FILESDIR}"/${P}-glib-2.31.patch #419395
+
+ eautoreconf # update libtool for interix
+}
+
+src_configure() {
+ econf --enable-animation
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog README
+ newdoc debian/changelog ChangeLog.debian
+ find "${ED}"/usr -name '*.la' -type f -exec rm -f {} +
+}