summaryrefslogtreecommitdiff
path: root/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild')
-rw-r--r--x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
new file mode 100644
index 000000000000..91f6b0df9293
--- /dev/null
+++ b/x11-themes/gtk-engines-nodoka/gtk-engines-nodoka-0.7.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit eutils
+
+MY_P="gtk-nodoka-engine-${PV}"
+
+DESCRIPTION="GTK+ engine and themes developed by the Fedora Project"
+HOMEPAGE="https://fedorahosted.org/nodoka/"
+SRC_URI="https://fedorahosted.org/releases/n/o/nodoka/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="animation-rtl"
+
+RDEPEND=">=x11-libs/gtk+-2.18.0:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-glib2.32.patch"
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-animation \
+ $(use_enable animation-rtl animationtoleft)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}