summaryrefslogtreecommitdiff
path: root/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild')
-rw-r--r--x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild b/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild
new file mode 100644
index 000000000000..c7ff7f338082
--- /dev/null
+++ b/x11-themes/gnustep-neos-theme/gnustep-neos-theme-0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils gnustep-2
+
+DESCRIPTION="GNUstep theme closely following the original NeXT look and feel"
+HOMEPAGE="http://gap.nongnu.org/themes/index.html"
+SRC_URI="https://savannah.nongnu.org/download/gap/Neos-${PV}.theme.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S=${WORKDIR}
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ ecvs_clean
+}
+
+src_compile() { :; }
+
+src_install() {
+ egnustep_env
+
+ #install themes
+ insinto ${GNUSTEP_SYSTEM_LIBRARY}/Themes
+ doins -r "${S}"/*theme
+}
+
+pkg_postinst() {
+ elog "Use gnustep-apps/systempreferences to switch theme"
+}