summaryrefslogtreecommitdiff
path: root/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild')
-rw-r--r--x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
new file mode 100644
index 000000000000..cf2458d831ec
--- /dev/null
+++ b/x11-themes/gentoo-xcursors/gentoo-xcursors-0.3.2-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A high quality set of animated mouse cursors"
+HOMEPAGE="https://schlomp.space/tastytea/gentoo-xcursors"
+SRC_URI="https://schlomp.space/tastytea/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r cursors/*
+
+ # Add symlinks in Gentoo-specific location for backwards compatibility, #848606
+ mkdir -p ${ED}/usr/share/cursors/xorg-x11 || die
+ cd ${ED}/usr/share/cursors/xorg-x11 || die
+ for cursorset in ../../icons/*; do
+ dosym ${cursorset} /usr/share/cursors/xorg-x11/${cursorset##*/}
+ done
+}
+
+pkg_postinst() {
+ einfo "To use this set of cursors, consult <https://wiki.gentoo.org/wiki/Cursor_themes>."
+ einfo "The three sets installed are gentoo, gentoo-silver and gentoo-blue."
+}