summaryrefslogtreecommitdiff
path: root/x11-themes/fluent-icon-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /x11-themes/fluent-icon-theme
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'x11-themes/fluent-icon-theme')
-rw-r--r--x11-themes/fluent-icon-theme/Manifest3
-rw-r--r--x11-themes/fluent-icon-theme/fluent-icon-theme-2021.12.20.ebuild56
-rw-r--r--x11-themes/fluent-icon-theme/metadata.xml25
3 files changed, 84 insertions, 0 deletions
diff --git a/x11-themes/fluent-icon-theme/Manifest b/x11-themes/fluent-icon-theme/Manifest
new file mode 100644
index 000000000000..ad136499e02e
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/Manifest
@@ -0,0 +1,3 @@
+DIST fluent-icon-theme-2021.12.20.tar.gz 33924235 BLAKE2B 17f051f086858ceb9969a8cacf6bbd2a9efd2e19d98872866ec5d9ea40e0389f3f9ad451dd6ed449716108eee20ad34fff1b121b497b4323314868bb1fb4429e SHA512 fc5e131c90f9444c92d0305489350f590f29dd78f03dd090959db00a1415a0bd35998e25ed93213c176536fa31e780942593b5d5470e4aac6fe98eb066463fa8
+EBUILD fluent-icon-theme-2021.12.20.ebuild 1330 BLAKE2B ce342f063d645089b3951d22537c5187da90967c22d36400af1cd2797f34bfc26327202a98b5cfd836500043f78e4c0fa67fc30c83500a9f0281a563a0ef2722 SHA512 a6d7789cbccb4960f146d17cbb73a6b386ecf4c86c872c64281aea51d8b98626bbb807bbd00a22060104b41c2a744a07bcbbd2f8e4d8784bf62900b26e468e05
+MISC metadata.xml 761 BLAKE2B 6ff0f7e9cfd1ed82e6e34e8b730fa60ecfb4827467b5f0bc9aa94df860f54a28ad30290526046d28f952d794bbd287e000634fa24ea9a9aa9a4b088f076900c9 SHA512 54b5cb1d7da3a7098ec9e538c35c0e96349dcf828206d7ae7588444bd82e2a95b3a95306db1ec598b0684157133278386dacd48763d993669cc6269e0a5b4288
diff --git a/x11-themes/fluent-icon-theme/fluent-icon-theme-2021.12.20.ebuild b/x11-themes/fluent-icon-theme/fluent-icon-theme-2021.12.20.ebuild
new file mode 100644
index 000000000000..82a474b46799
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/fluent-icon-theme-2021.12.20.ebuild
@@ -0,0 +1,56 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ie. 2021.12.20 -> 2021-12-20
+MY_PV="${PV//./-}"
+MY_PN="${PN^}"
+
+inherit xdg
+
+DESCRIPTION="Fluent icon theme for Linux desktops"
+HOMEPAGE="https://github.com/vinceliuice/Fluent-icon-theme"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vinceliuice/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/vinceliuice/${MY_PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_PN}-${MY_PV}"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="+black +hardlink round"
+RESTRICT="binchecks strip test"
+
+BDEPEND="sys-apps/util-linux[hardlink(-)?]"
+
+src_prepare() {
+ default
+
+ sed -i '/gtk-update-icon-cache/d' install.sh || die
+}
+
+src_install() {
+ dodir /usr/share/icons
+ local myinstallopts=(
+ --all
+ --dest "${ED}/usr/share/icons"
+ $(usev black '--black')
+ $(usev round '--round')
+ )
+ bash ./install.sh "${myinstallopts[@]}" || die "install script failed"
+
+ if use hardlink; then
+ einfo "Linking duplicate icons... (may take a long time)"
+ hardlink -pot "${ED}/usr/share/icons" || die "hardlink failed"
+ fi
+
+ # installs broken symlink (by design, but we remove it due to QA warnings)
+ find "${ED}" -xtype l -delete || die "removing broken symlinks failed"
+
+ einstalldocs
+}
diff --git a/x11-themes/fluent-icon-theme/metadata.xml b/x11-themes/fluent-icon-theme/metadata.xml
new file mode 100644
index 000000000000..93627ffdc59e
--- /dev/null
+++ b/x11-themes/fluent-icon-theme/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/vinceliuice/Fluent-icon-theme/issues</bugs-to>
+ <remote-id type="github">vinceliuice/Fluent-icon-theme</remote-id>
+ </upstream>
+ <use>
+ <flag name="black">
+ Install the black version of symbolic icons
+ (for white color-scheme panels)
+ </flag>
+ <flag name="hardlink">
+ Hardlink duplicate icons to greatly reduce installation size
+ </flag>
+ <flag name="round">
+ Install the round version of symbolic icons
+ </flag>
+ </use>
+</pkgmetadata>