summaryrefslogtreecommitdiff
path: root/x11-terms
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-20 11:40:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-20 11:40:14 +0000
commit11d4aa3149c1654953e22c50bf718b340406b158 (patch)
tree00a7d2ae92a6bc09e8668eb94a96384a303f1706 /x11-terms
parente660fe12946bfa241d169ebb2467939907de75d8 (diff)
gentoo auto-resync : 20:01:2023 - 11:40:14
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/Manifest.gzbin4558 -> 4559 bytes
-rw-r--r--x11-terms/guake/Manifest2
-rw-r--r--x11-terms/guake/guake-3.9.0.ebuild87
3 files changed, 89 insertions, 0 deletions
diff --git a/x11-terms/Manifest.gz b/x11-terms/Manifest.gz
index 0155a674afc5..46c4ec4c6242 100644
--- a/x11-terms/Manifest.gz
+++ b/x11-terms/Manifest.gz
Binary files differ
diff --git a/x11-terms/guake/Manifest b/x11-terms/guake/Manifest
index e61ee0b2d01e..71924d303cbf 100644
--- a/x11-terms/guake/Manifest
+++ b/x11-terms/guake/Manifest
@@ -1,3 +1,5 @@
DIST guake-3.8.5.gh.tar.gz 1112897 BLAKE2B 221e6a388c3a5904cd20a762e6a669e30b59a742a550e5c2a411534c3b0730c7622f42c67fdc72785fac199c432a297beb9fb53be2b5e2b7545a5b03c2b8b545 SHA512 40605fadb3a0149ea488a7e93f1b7e4f5250f62fe058292f2c02f03f837f22e13171b28c4a9d1a14c2e4897c0066a683cae547e03862397310bc650d149181fb
+DIST guake-3.9.0.gh.tar.gz 1118696 BLAKE2B 0c9fdcc5ff11d2f7263154594060a2145cefe678410cebb562dfd355a375019870a240ba4fb3868e69fdb5cf5bf49e73c3c5c2a1acef00251f68feebd8efdeba SHA512 d90e8a12285cd7488fe1132dc5af05d5eccec19a43ae98202631a15d12dfd21c3bda542e5f31ec409481d987a1bd013892c9343e7a74405a784e530efbd83503
EBUILD guake-3.8.5-r1.ebuild 2320 BLAKE2B 26872f816ed222a6cdc63506b8e70573f648ee4d4ad900075c5b9816fff98d90ba911ae1c92828b1824d5c6da1cea3a7f66f5f3727224165cc811efe1390f690 SHA512 fad17805eb7cee1f161e6b797bcaef275581562a4c94a26526d47fa946a599899ce7d79a049af362c2f790c437d6444e739907ed0d7854b8ebdef23182fb30e4
+EBUILD guake-3.9.0.ebuild 2380 BLAKE2B b29002bf01ddcd7f8ee1ebcab2ea3de8e40517b15af2b83e9345c967d5a509a7a56334af09d4ac88f635b702f61c9159225f682bcf75a4db578bae4bafc48a36 SHA512 4c1efc0c577003075030d352752a945125bc4fe527a9582aa368347d8631f6c2baa07afccf54f593e7af0a34a3f5dbd3549538533da5cb4e09a65c3c750cd96b
MISC metadata.xml 418 BLAKE2B 4eaf1e46ca71463bf5e7c54f31941d391851b2415872e06e41bc97b8d2278ac58c544ff869a5050e4d20abc670c20d4c7d364a8d68a7d9fb21baae2fa061af69 SHA512 52a8f383fc6bd2757dfc41fd0758c2b47ee177ecf49bf840a4e8ee8b32421a8f3c6a08270fa72f8cd2d87f8bfe663390ae18f17ea9ad18715099fe575de726d1
diff --git a/x11-terms/guake/guake-3.9.0.ebuild b/x11-terms/guake/guake-3.9.0.ebuild
new file mode 100644
index 000000000000..737722966865
--- /dev/null
+++ b/x11-terms/guake/guake-3.9.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 gnome2-utils optfeature plocale virtualx xdg
+
+PLOCALES="ca cs de el es fa fi fr gl hr hu id it ja ko nb nl pa pl pt_BR ru sv tr uk zh_CN zh_TW"
+
+DESCRIPTION="Drop-down terminal for GNOME"
+HOMEPAGE="http://guake-project.org/"
+SRC_URI="https://github.com/Guake/guake/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]')
+ dev-libs/keybinder:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/libwnck:3[introspection]
+ x11-libs/vte:2.91[introspection]"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )')
+ dev-libs/glib:2
+ gnome-base/gsettings-desktop-schemas
+ sys-devel/gettext"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ export SETUPTOOLS_SCM_PRETEND_VERSION=${PV} # needed with github's tarball
+
+ local po=($(plocale_get_locales disabled))
+ po=("${po[@]/%/.po}")
+ (( ! ${#po[@]} )) || rm "${po[@]/#/po/}" || die
+
+ emake PREFIX="${EPREFIX}"/usr prepare-install # paths.py.in -> paths.py
+}
+
+python_test() {
+ # - uses /usr/bin/bash if SHELL is not exported
+ SHELL=${SHELL} virtx epytest
+}
+
+python_install() {
+ # use right schema/data dirs, done here so tests don't use the system's
+ sed -e "/^SCHEMA_DIR/s|=.*|= \"${EPREFIX}/usr/share/glib-2.0/schemas\"|" \
+ -e "/def get_default_data_dir/{n;s|=.*|= \"${EPREFIX}/usr/share/guake\"|}" \
+ -i "${BUILD_DIR}/install$(python_get_sitedir)"/guake/paths.py || die
+ python_optimize "${BUILD_DIR}/install$(python_get_sitedir)"/guake/paths.py
+
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install-{locale,schemas}
+
+ dodoc NEWS.rst README.rst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "utmp management support" sys-libs/libutempter
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}