summaryrefslogtreecommitdiff
path: root/x11-terms/xvt/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /x11-terms/xvt/files
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'x11-terms/xvt/files')
-rw-r--r--x11-terms/xvt/files/xvt-int-main.patch23
-rw-r--r--x11-terms/xvt/files/xvt-makefile.patch20
-rw-r--r--x11-terms/xvt/files/xvt-pts.patch12
-rw-r--r--x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff63
4 files changed, 0 insertions, 118 deletions
diff --git a/x11-terms/xvt/files/xvt-int-main.patch b/x11-terms/xvt/files/xvt-int-main.patch
deleted file mode 100644
index a0874e45f419..000000000000
--- a/x11-terms/xvt/files/xvt-int-main.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/xvt.c
-+++ b/xvt.c
-@@ -41,9 +41,9 @@
- #endif /* UKC_LOCATIONS */
-
- #ifdef __STDC__
--void main(int,char **);
-+int main(int,char **);
- #else
--void main();
-+int main();
- #endif
-
- extern int debugging;
-@@ -67,7 +67,7 @@
- * master end of the pseudo-teletype pair with the command talking to
- * the slave.
- */
--void
-+int
- main(argc,argv)
- int argc;
- char **argv;
diff --git a/x11-terms/xvt/files/xvt-makefile.patch b/x11-terms/xvt/files/xvt-makefile.patch
deleted file mode 100644
index b147d9d8c2b9..000000000000
--- a/x11-terms/xvt/files/xvt-makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -27,7 +27,7 @@
- #ARCH=AIX3
- #ARCH=ULTRIX
- #ARCH=HPUX
--#ARCH=LINUX
-+ARCH=LINUX
- #
- #
- # If this line is uncommented then `Make config' will unclude several options
-@@ -107,7 +107,7 @@
- OBJ=xvt.o xsetup.o command.o screen.o sbar.o ttyinit.o
- SRC=xvt.c xsetup.c command.c screen.c sbar.c ttyinit.c
- #
--CFLAGS=-O $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
-+CFLAGS+= $(INCLUDE) $(OPTIONS) $(DEFS) -D$(ARCH)
- #
- xvt: $(OBJ)
- $(CC) $(LDFLAGS) -o xvt $(OBJ) $(LIB) -lX11
diff --git a/x11-terms/xvt/files/xvt-pts.patch b/x11-terms/xvt/files/xvt-pts.patch
deleted file mode 100644
index a86504ad29e5..000000000000
--- a/x11-terms/xvt/files/xvt-pts.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/ttyinit.c
-+++ b/ttyinit.c
-@@ -25,6 +25,9 @@
-
- char xvt_ttyinit_c_sccsid[] = "@(#)ttyinit.c 1.3 11/1/94 (UKC)";
-
-+#ifdef LINUX
-+#define _XOPEN_SOURCE
-+#endif
- #ifdef __STDC__
- #include <stdarg.h>
- #else
diff --git a/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff b/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
deleted file mode 100644
index 1cc370b94d7a..000000000000
--- a/x11-terms/xvt/files/xvt-ttyinit-svr4pty.diff
+++ /dev/null
@@ -1,63 +0,0 @@
---- a/ttyinit.c
-+++ b/ttyinit.c
-@@ -46,6 +46,7 @@
- #include <pwd.h>
- #include <errno.h>
- #include <string.h>
-+#include <stropts.h>
- #include "xvt.h"
- #include "token.h"
- #include "command.h"
-@@ -410,44 +411,6 @@
- get_pseudo_tty(pmaster,pslave)
- int *pmaster, *pslave;
- {
--#ifdef BSD_PTY
-- int mfd, sfd;
-- char *s3, *s4;
-- static char ptyc3[] = "pqrstuvwxyz";
-- static char ptyc4[] = "0123456789abcdef";
-- static char ptynam[] = "/dev/ptyxx";
-- static char ttynam[] = "/dev/ttyxx";
--
-- /* First find a master pty that we can open.
-- */
-- mfd = -1;
-- for (s3 = ptyc3; *s3 != 0; s3++) {
-- for (s4 = ptyc4; *s4 != 0; s4++) {
-- ptynam[8] = ttynam[8] = *s3;
-- ptynam[9] = ttynam[9] = *s4;
-- if ((mfd = open(ptynam,O_RDWR)) >= 0) {
-- if (geteuid() == 0 || access(ttynam,R_OK|W_OK) == 0)
-- break;
-- else {
-- close(mfd);
-- mfd = -1;
-- }
-- }
-- }
-- if (mfd >= 0)
-- break;
-- }
-- if (mfd < 0) {
-- error("Can't open a pseudo teletype");
-- return(NULL);
-- }
-- if ((sfd = open(ttynam,O_RDWR)) < 0) {
-- error("could not open slave tty %s",ttynam);
-- return(NULL);
-- }
--#endif /* BSD_PTY */
--
--#ifdef SVR4_PTY
- char *ttynam;
- int mfd, sfd;
-
-@@ -464,7 +427,6 @@
- }
- ioctl(sfd,I_PUSH,"ptem");
- ioctl(sfd,I_PUSH,"ldterm");
--#endif /* SVR4_PTY */
-
- *pslave = sfd;
- *pmaster = mfd;