summaryrefslogtreecommitdiff
path: root/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild')
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild93
1 files changed, 93 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
new file mode 100644
index 000000000000..43645a40943a
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9999.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools cvs eutils
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+ECVS_SERVER="cvs.schmorp.de/schmorpforge"
+ECVS_USER="anonymous"
+ECVS_MODULE="rxvt-unicode"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS=""
+IUSE="
+ 256-color blink fading-colors +font-styles iso14755 +mousewheel +perl
+ pixbuf startup-notification xft unicode3
+"
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/fontconfig
+ sys-libs/ncurses:*
+ x11-libs/libX11
+ x11-libs/libXrender
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ perl? ( dev-lang/perl:= )
+ pixbuf? ( x11-libs/gdk-pixbuf x11-libs/gtk+:2 )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xproto
+"
+
+S=${WORKDIR}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+
+)
+
+src_prepare() {
+ ecvs_clean
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die
+
+ eapply_user
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=''
+
+ use iso14755 || myconf='--disable-iso14755'
+
+ # --enable-everything goes first: the order of the arguments matters
+ econf --enable-everything \
+ $(use_enable 256-color) \
+ $(use_enable blink text-blink) \
+ $(use_enable fading-colors fading) \
+ $(use_enable font-styles) \
+ $(use_enable iso14755) \
+ $(use_enable mousewheel) \
+ $(use_enable perl) \
+ $(use_enable pixbuf) \
+ $(use_enable startup-notification) \
+ $(use_enable unicode3) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ dodoc \
+ README.FAQ Changes doc/README* doc/changes.txt doc/etc/* doc/rxvt-tabbed
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}