summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/kitty-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
commitd3fc35858ba4bc0c8038a8c536246b00fe648358 (patch)
tree416e79067bd12fc0b43e12f1b73ee15a62b8a5bf /x11-terms/kitty/kitty-9999.ebuild
parent2512faa12f58e69a2f3e27e13e10fd0aef3ab384 (diff)
gentoo auto-resync : 29:08:2022 - 10:46:12
Diffstat (limited to 'x11-terms/kitty/kitty-9999.ebuild')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 92a0509aac27..3ee9cbb30121 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
-inherit optfeature multiprocessing python-single-r1 toolchain-funcs xdg
+inherit edo optfeature multiprocessing python-single-r1 toolchain-funcs xdg
if [[ ${PV} == 9999 ]] ; then
inherit git-r3
@@ -32,6 +32,7 @@ RESTRICT="!X? ( test ) !test? ( test ) !transfer? ( test ) !wayland? ( test )"
# dlopen: fontconfig,libglvnd
RDEPEND="
${PYTHON_DEPS}
+ dev-libs/openssl:=
media-libs/fontconfig
media-libs/harfbuzz:=
media-libs/lcms:2
@@ -67,9 +68,10 @@ BDEPEND="
src_prepare() {
default
+ # seds unfortunately feel easier on maintainenance than patches here
sed -e "s/'x11 wayland'/'$(usev X x11) $(usev wayland)'/" \
-e "$(usev !X '/gl_libs =/s/=.*/= []/')" \
- -e "/num_workers = /s/=.*/= $(makeopts_jobs)/" \
+ -e "/num_workers =/s/=.*/= $(makeopts_jobs)/" \
-e "s/cflags.append.*-O3.*/pass/" -e 's/-O3//' \
-i setup.py || die
@@ -92,8 +94,7 @@ src_compile() {
tc-export CC
export PKGCONFIG_EXE=$(tc-getPKG_CONFIG)
- local setup=(
- ${EPYTHON} setup.py linux-package
+ local conf=(
--disable-link-time-optimization
--ignore-compiler-warnings
--libdir-name=$(get_libdir)
@@ -102,16 +103,15 @@ src_compile() {
--verbose
)
- echo "${setup[*]}"
- "${setup[@]}" || die "setup.py failed to compile ${PN}"
+ edo ${EPYTHON} setup.py linux-package "${conf[@]}"
+ use test && edo ${EPYTHON} setup.py build-launcher "${conf[@]}"
[[ ${PV} == 9999 ]] || mv linux-package/share/doc/{${PN},${PF}} || die
rm -r linux-package/share/terminfo || die
}
src_test() {
- PATH=linux-package/bin:${PATH} KITTY_CONFIG_DIRECTORY=${T} \
- ${EPYTHON} test.py || die
+ KITTY_CONFIG_DIRECTORY=${T} ./test.py || die # shebang is kitty
}
src_install() {