summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/kitty-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /x11-terms/kitty/kitty-9999.ebuild
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'x11-terms/kitty/kitty-9999.ebuild')
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index a458d0c67387..8bef706b26df 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_COMPAT=( python3_6 )
inherit python-single-r1 toolchain-funcs gnome2-utils
@@ -45,11 +45,12 @@ RDEPEND="
"
DEPEND="${RDEPEND}
virtual/pkgconfig
+ >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]
"
PATCHES=(
- "${FILESDIR}"/${PN}-0.9.1-flags.patch
- "${FILESDIR}"/${PN}-0.7.1-svg-icon.patch
+ "${FILESDIR}"/${PN}-0.11.0-flags.patch
+ "${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
)
src_prepare() {
@@ -60,6 +61,9 @@ src_prepare() {
sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
fi
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py
+
tc-export CC
}
@@ -81,8 +85,6 @@ src_install() {
mkdir -p "${ED}"usr || die
cp -r linux-package/* "${ED}usr" || die
python_fix_shebang "${ED}"
-
- dodoc CHANGELOG.rst *.asciidoc
}
pkg_postinst() {