summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-16 21:23:20 +0100
commitfab849d1daed0ba7f2ac497d07985c3dbb692543 (patch)
tree10baa743a5340b42ad538dd19d48669ccac209b1 /x11-terms/kitty/files
parent73c318acdaf6f8309d68bd266051e6dd1f1bd787 (diff)
gentoo resync : 16.06.2019
Diffstat (limited to 'x11-terms/kitty/files')
-rw-r--r--x11-terms/kitty/files/kitty-0.14.2-flags.patch (renamed from x11-terms/kitty/files/kitty-0.11.0-flags.patch)20
1 files changed, 11 insertions, 9 deletions
diff --git a/x11-terms/kitty/files/kitty-0.11.0-flags.patch b/x11-terms/kitty/files/kitty-0.14.2-flags.patch
index 44abfb669a0c..d362c4216511 100644
--- a/x11-terms/kitty/files/kitty-0.11.0-flags.patch
+++ b/x11-terms/kitty/files/kitty-0.14.2-flags.patch
@@ -1,6 +1,8 @@
---- kitty-0.11.0/setup.py
-+++ kitty-0.11.0/setup.py
-@@ -177,7 +177,7 @@
+Respect user CFLAGS.
+
+--- kitty-0.14.2/setup.py
++++ kitty-0.14.2/setup.py
+@@ -198,7 +198,7 @@
df = '-g3'
if ccver >= (5, 0):
df += ' -Og'
@@ -9,16 +11,16 @@
sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
cppflags = os.environ.get(
'OVERRIDE_CPPFLAGS', (
-@@ -190,7 +190,7 @@
+@@ -213,7 +213,7 @@
cflags = os.environ.get(
'OVERRIDE_CFLAGS', (
- '-Wextra -Wno-missing-field-initializers -Wall -std=c99'
+ '-Wextra -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
-+ ' -pedantic {} {} -fwrapv {} {} {} -fvisibility=hidden'
++ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
).format(
optimize,
' '.join(sanitize_args),
-@@ -204,7 +204,7 @@
+@@ -227,7 +227,7 @@
)
ldflags = os.environ.get(
'OVERRIDE_LDFLAGS',
@@ -27,10 +29,10 @@
)
ldflags = shlex.split(ldflags)
ldflags.append('-shared')
-@@ -505,14 +505,14 @@
+@@ -550,14 +550,14 @@
- def build_linux_launcher(args, launcher_dir='.', for_bundle=False, sh_launcher=False, for_freeze=False):
+ def build_launcher(args, launcher_dir='.', for_bundle=False, sh_launcher=False, for_freeze=False):
- cflags = '-Wall -Werror -fpie'.split()
+ cflags = '-Wall -fpie'.split()
cppflags = []