summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-terms/kitty/files
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-terms/kitty/files')
-rw-r--r--x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch14
-rw-r--r--x11-terms/kitty/files/kitty-0.17.2-flags.patch50
2 files changed, 64 insertions, 0 deletions
diff --git a/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch b/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch
new file mode 100644
index 000000000000..4b7352aa73b3
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.16.0-remove-terminfo.patch
@@ -0,0 +1,14 @@
+--- a/setup.py
++++ b/setup.py
+@@ -837,11 +837,6 @@
+ safe_makedirs(launcher_dir)
+ build_launcher(args, launcher_dir, bundle_type)
+ os.makedirs(os.path.join(libdir, 'logo'))
+- build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
+- for x in (libdir, os.path.join(ddir, 'share')):
+- odir = os.path.join(x, 'terminfo')
+- safe_makedirs(odir)
+- build_terminfo['compile_terminfo'](odir)
+ shutil.copy2('__main__.py', libdir)
+ shutil.copy2('logo/kitty.rgba', os.path.join(libdir, 'logo'))
+ shutil.copy2('logo/kitty.png', os.path.join(libdir, 'logo'))
diff --git a/x11-terms/kitty/files/kitty-0.17.2-flags.patch b/x11-terms/kitty/files/kitty-0.17.2-flags.patch
new file mode 100644
index 000000000000..5a247679dc82
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.17.2-flags.patch
@@ -0,0 +1,50 @@
+Respect user CFLAGS.
+
+--- a/setup.py
++++ b/setup.py
+@@ -236,7 +236,7 @@
+ if ccver >= (5, 0):
+ df += ' -Og'
+ float_conversion = '-Wfloat-conversion'
+ fortify_source = '-D_FORTIFY_SOURCE=2'
+- optimize = df if debug or sanitize else '-O3'
++ optimize = ''
+ sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+ cppflags_ = os.environ.get(
+ 'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
+@@ -217,7 +217,7 @@
+ cflags = os.environ.get(
+ 'OVERRIDE_CFLAGS', (
+ '-Wextra {} -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
+- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
++ ' -pedantic-errors {} {} -fwrapv {} {} {} -fvisibility=hidden'
+ ).format(
+ float_conversion, std,
+ optimize,
+@@ -232,7 +232,7 @@
+ )
+ ldflags = os.environ.get(
+ 'OVERRIDE_LDFLAGS',
+- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++ '-Wall ' + ' '.join(sanitize_args)
+ )
+ ldflags = shlex.split(ldflags)
+ ldflags.append('-shared')
+@@ -614,7 +614,7 @@
+
+
+ def build_launcher(args, launcher_dir='.', bundle_type='source'):
+- cflags = '-Wall -Werror -fpie'.split()
++ cflags = '-Wall -fpie'.split()
+ cppflags = []
+ libs = []
+ if args.profile or args.sanitize:
+@@ -626,8 +626,6 @@
+ cflags.append('-g')
+ if args.profile:
+ libs.append('-lprofiler')
+- else:
+- cflags.append('-O3')
+ if bundle_type.endswith('-freeze'):
+ cppflags.append('-DFOR_BUNDLE')
+ cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))