summaryrefslogtreecommitdiff
path: root/x11-terms/kitty/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-08 14:01:34 +0100
commit4645b6f17f0da81e9fe84081fb126a37102ba153 (patch)
treee6c48cf3db2213af38cf528a5364fffd5c74c6d6 /x11-terms/kitty/files
parentebce8994fe3cc4ca9fbc96ca837cb4c4e98adcbd (diff)
gentoo resync : 08.05.2018
Diffstat (limited to 'x11-terms/kitty/files')
-rw-r--r--x11-terms/kitty/files/kitty-0.9.1-flags.patch47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-terms/kitty/files/kitty-0.9.1-flags.patch b/x11-terms/kitty/files/kitty-0.9.1-flags.patch
new file mode 100644
index 000000000000..9c544610b6b7
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-0.9.1-flags.patch
@@ -0,0 +1,47 @@
+--- kitty-0.9.1/setup.py
++++ kitty-0.9.1/setup.py
+@@ -178,7 +178,7 @@
+ df = '-g3'
+ if ccver >= (5, 0):
+ df += ' -Og'
+- optimize = df if debug or sanitize else '-O3'
++ optimize = ''
+ sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
+ cppflags = os.environ.get(
+ 'OVERRIDE_CPPFLAGS', (
+@@ -191,7 +191,7 @@
+ cflags = os.environ.get(
+ 'OVERRIDE_CFLAGS', (
+ '-Wextra -Wno-missing-field-initializers -Wall -std=c99'
+- ' -pedantic-errors -Werror {} {} -fwrapv {} {} -pipe {} -fvisibility=hidden'
++ ' -pedantic {} {} -fwrapv {} {} {} -fvisibility=hidden'
+ ).format(
+ optimize,
+ ' '.join(sanitize_args),
+@@ -205,7 +205,7 @@
+ )
+ ldflags = os.environ.get(
+ 'OVERRIDE_LDFLAGS',
+- '-Wall ' + ' '.join(sanitize_args) + ('' if debug else ' -O3')
++ '-Wall ' + ' '.join(sanitize_args)
+ )
+ ldflags = shlex.split(ldflags)
+ ldflags.append('-shared')
+@@ -508,14 +508,14 @@
+
+
+ def build_linux_launcher(args, launcher_dir='.', for_bundle=False, sh_launcher=False):
+- cflags = '-Wall -Werror -fpie'.split()
++ cflags = '-Wall -fpie'.split()
+ cppflags = []
+ libs = []
+ if args.profile:
+ cppflags.append('-DWITH_PROFILER'), cflags.append('-g')
+ libs.append('-lprofiler')
+- else:
+- cflags.append('-O3')
++ # else:
++ # cflags.append('-O3')
+ if for_bundle:
+ cppflags.append('-DFOR_BUNDLE')
+ cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))