summaryrefslogtreecommitdiff
path: root/x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild')
-rw-r--r--x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild b/x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild
new file mode 100644
index 000000000000..3caea52faf35
--- /dev/null
+++ b/x11-terms/cool-retro-term/cool-retro-term-1.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils xdg
+
+QTW_PN="qmltermwidget"
+QTW_PV=63228027e1f97c24abb907550b22ee91836929c5
+QTW_P="${QTW_PN}-${QTW_PV}"
+
+DESCRIPTION="Terminal emulator with an old school look and feel"
+HOMEPAGE="https://github.com/Swordfish90/cool-retro-term/"
+
+SRC_URI="
+ https://github.com/Swordfish90/cool-retro-term/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Swordfish90/qmltermwidget/archive/${QTW_PV}.tar.gz -> ${QTW_P}.tar.gz
+"
+
+LICENSE="BSD GPL-2+ GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5[localstorage]
+ dev-qt/qtgraphicaleffects:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtquickcontrols:5[widgets]
+ dev-qt/qtquickcontrols2:5[widgets]
+ dev-qt/qtwidgets:5
+"
+
+RDEPEND="${DEPEND}
+ virtual/opengl"
+
+src_prepare() {
+ default
+
+ rmdir "${QTW_PN}" || die
+ mv "${WORKDIR}/${QTW_P}" "${QTW_PN}" || die
+}
+
+src_configure() {
+ eqmake5 PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ # `default` attempts to install directly to /usr and parallelised
+ # installation is not supported as `qmake5 -install` does not implictly
+ # create target directory.
+
+ emake -j1 INSTALL_ROOT="${ED}" install
+ doman "packaging/debian/cool-retro-term.1"
+
+ insinto "/usr/share/metainfo"
+ doins "packaging/appdata/cool-retro-term.appdata.xml"
+}