summaryrefslogtreecommitdiff
path: root/x11-proto
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /x11-proto
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/Manifest.gzbin5652 -> 5652 bytes
-rw-r--r--x11-proto/xcb-proto/Manifest2
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.13.ebuild63
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-proto/Manifest.gz b/x11-proto/Manifest.gz
index 86495cf75594..f219ff627f53 100644
--- a/x11-proto/Manifest.gz
+++ b/x11-proto/Manifest.gz
Binary files differ
diff --git a/x11-proto/xcb-proto/Manifest b/x11-proto/xcb-proto/Manifest
index dff65653ddcb..b0a55edadd18 100644
--- a/x11-proto/xcb-proto/Manifest
+++ b/x11-proto/xcb-proto/Manifest
@@ -2,5 +2,7 @@ AUX xcb-proto-1.12-make-whitespace-usage-consistent.patch 8518 BLAKE2B 599038dc8
AUX xcb-proto-1.12-print-is-a-function-and-needs-parentheses.patch 3328 BLAKE2B 30b6fd8e44056b62a67442612c905f2ac2dea5ff67f549326ef3c00ad526efac13c0a4708b38434497c8106b84d369f49812095dafb6d6a286a2c5075a24945c SHA512 b541295721d8cf87d1079c3366401dff3830bc953082b9f9c0376163ef5893a1f111d278904caed8d54f2796b255c6f12043d7353bd3605e040a2a355e76f15e
AUX xcb-proto-1.12-update-xml-schema.patch 6196 BLAKE2B 86026b2845d897fa58101915433a73e733fae54f9526892f2bf5ed0cfd710e5b06219054f8668df8ae4a9b6d8df7fab5491f3f1fef50651423453c4bd0ddc024 SHA512 7b4875e528fa0bd07a1d4ab214b7fa059ae8180b02262ca608bb6d07f98ef05bc66e5188b84cb2ab795589328d2ab8a63282785611d073f09e31b554d264fab4
DIST xcb-proto-1.12.tar.bz2 153890 BLAKE2B cdb4b245e838ca56bfdcaa9a0618ce45e5d4da8ee10f7ae3389ff297325c3d81ba446a6385737cc9b053ecb06a0c829d99ab27dceecfec49ac1591c25c832c46 SHA512 1f427eaf223971b25b56c9f641350e03f5ebeb17a1fc212ce2a0c892de7aba7e53d5e3958b073a122bb344c387c0ff394cf96f542ff046f33de4e1cd27fb9e5c
+DIST xcb-proto-1.13.tar.bz2 151981 BLAKE2B 04d90838f8a892103e6d7aa807f1b0b6794f1538c6c986ad3cba67cff3a963ff680e45c2137c5d6330736a3aa1a387d61fc247f23487de9dada2f4013590b4a1 SHA512 002aa2aa0ad503977e03419c6f136f1e3aa8c787916830ce6d6be8f81ca99edc1d8fc5f71ce8c592b490cc767bf6567695f0bafe55fe3f743076bcddbaac07f7
EBUILD xcb-proto-1.12-r2.ebuild 1711 BLAKE2B 4116201d5e1d186318a5bb1f8a4866ccd46be9ce1c99c6c4ead5bddc731e1140f9ddf1912f3f8e2d7baf0bb0261cfa8a1b5c6dc673cc2c00a47361288831e70d SHA512 6345ebc3a9c0e1cabacc05050ca5f3888bae6d5c4ee23c58f7efe15655b64e7679efc4653ec9288b48a382a3ab94ff79e3b37d42e2f11cf815a263e92fcf5cb4
+EBUILD xcb-proto-1.13.ebuild 1537 BLAKE2B c72c3fc1355aea6d220ce6d59bf890990ff8334ccac2108f7ece6a138b1529367b6c6a9416b65399cd44a61f0597c6e01572d9498f6f9c9ddaa78381275b3b12 SHA512 d15fa2e4974ab9ba1f36918e8cde97c16974774e2ba6855f530ae1b7eee7c2b31025932d12ee9f5b01ee5d70933641aa90b9fca4d1221667ba7e901878f6bb81
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-proto/xcb-proto/xcb-proto-1.13.ebuild b/x11-proto/xcb-proto/xcb-proto-1.13.ebuild
new file mode 100644
index 000000000000..81add3e7b94f
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.13.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/"
+EGIT_REPO_URI="https://anongit.freedesktop.org/git/xcb/proto.git"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+src_configure() {
+ python_setup
+ xorg-2_src_configure
+}
+
+multilib_src_configure() {
+ autotools-utils_src_configure
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+src_install() {
+ xorg-2_src_install
+
+ # pkg-config file hardcodes python sitedir, bug 486512
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}