summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
commitf265f17242b04ae036b4dc174fa95401d895dbc5 (patch)
tree8daa848087a673b8bf5dad576b0a08048d551da7 /x11-plugins
parentd08ea43e9ada434f42f4be8e115b67ab22ce38af (diff)
gentoo auto-resync : 16:03:2024 - 18:48:51
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26771 -> 26776 bytes
-rw-r--r--x11-plugins/pidgin-gpg/Manifest3
-rw-r--r--x11-plugins/pidgin-gpg/files/pidgin-gpg-0.9.3_musl-support.patch32
-rw-r--r--x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3-r1.ebuild6
4 files changed, 39 insertions, 2 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 5524d096d71e..73b8698181f5 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/pidgin-gpg/Manifest b/x11-plugins/pidgin-gpg/Manifest
index 2dd68ddca066..3a2e98d37c4d 100644
--- a/x11-plugins/pidgin-gpg/Manifest
+++ b/x11-plugins/pidgin-gpg/Manifest
@@ -1,3 +1,4 @@
+AUX pidgin-gpg-0.9.3_musl-support.patch 1333 BLAKE2B 749114283008e655adf4add55138099512c825e7838402b163837a258973e8c2fbb921c1cec2d39cbe4213b394ea84359114096b78fe3da48a4240d899dd6fca SHA512 4bb38772b626ce65965f020b2f9af67bc66384f06bbd710b0d3cf24e80a95ef6ac846a8b63d1aa7a33c6ec553507545f0bb59b1e3fb05d162445b04841035929
DIST pidgin-gpg-0.9.3.tar.gz 806492 BLAKE2B 67ca75307419fe25d6a7f90ce33f63e736eae59e0cab9fd2fafbf7f9ccd61569fb9906e755163400c462bcd63fa8e9b1e42deb98e459fb9e070d73de9cfb28ab SHA512 bff7ec08d7999d40b689aabc0b559b7eab1fae765b6ffc799e355601ac3a2bb05c3831c1e56e30b95f387c446f7d07d1576af7e7824094fca9ac6c6636d62f6c
-EBUILD pidgin-gpg-0.9.3-r1.ebuild 614 BLAKE2B 9d38575594ebd672b40655b1edae9289cd57dfe60b6f7a2219e94eb5f47bae0f6764327df5e02eb438068085650ae22737411d2a4350cbbf1e72c5ef7bb953a8 SHA512 5756a17ab676be6559e90433346e422ea4e8c83ffa27f562b6564abf31779659eb8c3f05a9df536a068eea3595cde66aba5dd8cd4bd8d84fe1a8adb4311755b6
+EBUILD pidgin-gpg-0.9.3-r1.ebuild 678 BLAKE2B 9fefb3755ede58f5bc86e0d3634e6fe685b1f6437b21e56c12417f5e75cd7a539fad4ddeb2e61b0fefead54aef880c3b3f8f1ff199ed41e53aed25d5a28f598a SHA512 f5051d47bd741548b0917ad4f88c61eff8f850ebc44b149140e4ea6fe41c4198cca0bb3f3672532b8e573834ef260a0d3cf91da01aac160aa21fc7f6ebdcbae9
MISC metadata.xml 494 BLAKE2B d03b65c559618a45898700c534a1ff1f3762fe2743d441c18d32caab4825bc62065dc011b75b5bb62299ee6c5946e1fd2e5573860007d6657ce0c70982ddadd6 SHA512 156e6083f67c67e31393a1a5044f288cc1fb0206b5652e10711d53e75c9000195f36b864717070674565c4eb00eb723424aabef568f4e01feb26c8f3bd3e7387
diff --git a/x11-plugins/pidgin-gpg/files/pidgin-gpg-0.9.3_musl-support.patch b/x11-plugins/pidgin-gpg/files/pidgin-gpg-0.9.3_musl-support.patch
new file mode 100644
index 000000000000..47de6808fd5c
--- /dev/null
+++ b/x11-plugins/pidgin-gpg/files/pidgin-gpg-0.9.3_musl-support.patch
@@ -0,0 +1,32 @@
+From https://github.com/Draghtnod/Pidgin-GPG/pull/9
+From: "Azamat H. Hackimov" <azamat.hackimov@gmail.com>
+Date: Sat, 17 Feb 2024 13:28:40 +0300
+Subject: [PATCH] Fix compilation on MUSL systems
+
+In MUSL encrypt() is part of unistd.h, which conflicts with internal
+static function encrypt(). Renamed last one to fix that.
+
+See: https://bugs.gentoo.org/831185
+--- a/src/pidgin-gpg.c
++++ b/src/pidgin-gpg.c
+@@ -604,7 +604,7 @@ static char* verify( const char* sig_str ) {
+ * encrypt a plain string with the key found with fingerprint fpr
+ * FREE MEMORY AFTER USAGE OF RETURN VALUE!
+ * ------------------ */
+-static char* encrypt( gpgme_ctx_t* ctx, gpgme_key_t* key_arr, const char* plain_str, const char* fpr ) {
++static char* pidgin_gpg_encrypt( gpgme_ctx_t* ctx, gpgme_key_t* key_arr, const char* plain_str, const char* fpr ) {
+ if( ctx == NULL ) {
+ purple_debug_error( PLUGIN_ID, "encrypt: missing ctx\n" );
+ return NULL;
+@@ -1054,7 +1054,7 @@ void jabber_send_signal_cb( PurpleConnection* pc, xmlnode** packet, gpointer unu
+ g_free( bare_jid );
+
+ // encrypt message
+- enc_str = encrypt( &item->ctx, item->key_arr, message, item->fpr );
++ enc_str = pidgin_gpg_encrypt( &item->ctx, item->key_arr, message, item->fpr );
+ g_free( message );
+ if( enc_str != NULL ) {
+ // remove message from body
+--
+2.43.0
+
diff --git a/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3-r1.ebuild b/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3-r1.ebuild
index ac3eeac2c984..03ca90a1df37 100644
--- a/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3-r1.ebuild
+++ b/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -20,6 +20,10 @@ BDEPEND="virtual/pkgconfig"
S="${WORKDIR}/Pidgin-GPG-${PV}"
+PATCHES=(
+ "${FILESDIR}/pidgin-gpg-0.9.3_musl-support.patch"
+)
+
src_prepare() {
default
eautoreconf