summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 08:59:05 +0000
commite6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (patch)
tree6b38c918c796f792ef4b18b57437c05a1fd46ae8 /x11-plugins
parentfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (diff)
gentoo auto-resync : 03:12:2022 - 08:59:05
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin27373 -> 27368 bytes
-rw-r--r--x11-plugins/wmweather+/Manifest3
-rw-r--r--x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch67
-rw-r--r--x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild (renamed from x11-plugins/wmweather+/wmweather+-2.18.ebuild)5
4 files changed, 73 insertions, 2 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index d93b47a55db5..947138bf1187 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/wmweather+/Manifest b/x11-plugins/wmweather+/Manifest
index 16cdc65b8cde..3e1b36c5f6cb 100644
--- a/x11-plugins/wmweather+/Manifest
+++ b/x11-plugins/wmweather+/Manifest
@@ -1,4 +1,5 @@
AUX wmweather+-2.18-ar.patch 340 BLAKE2B 1ace1344fc5d84eb4f5eb8df4f30e091827ae6a4c349760d6173031843dce2316987c948cc4a73fe49b4613a5ce8fccf4299bdb7611597d67644223679daa216 SHA512 63f36eb87fc8fbe05c816301903607534e26cb0c8b4ff010fd740cd0a4b5776a4553e43a877c0d12d9d6c549df9277ae10e4e3ceac7d590f4a3a9e5d60699316
+AUX wmweather+-2.18-configure-clang16.patch 2608 BLAKE2B 6eaa69471dac8ccd6030835a7b1c2d552492758799e2dff0b6a770043da57fd887543cf826a7b3e56eb5792748b7d6dc5ef7d4efbf59ff046158c135eb6dc4e8 SHA512 fdf8170dcb0b946d6c857f961beb07a380f18fcc163a642ad9c8dba53a8932ccafef839a30062c8bdac2d1ca0eddf268ef1aaa93161adb6db686caf092a7683e
DIST wmweather+-2.18.tar.gz 206062 BLAKE2B 14fe0b49b5541d5e093c958d1c12c4c28c3bae53f8539402a61800d1817bf22eae426d4733e08ae3f1e90057e7dd297a9412d62e5edd9fb973b0a9e799b3f792 SHA512 538325b1d2bd7dd3a89a006d88868e02a71318b6e49001033d0f543965fb21f91b265e116d3b929a096e99719c99241d520a7eb395ec55f721de0d01dcbedbc0
-EBUILD wmweather+-2.18.ebuild 649 BLAKE2B 48368e7cb7e9eca9ff1d5265a470bdef077543a7f0e2e208ae6ecbdb42a868d73967084ba31d6ae74b7724a20b4c3525a82c93c5e4893623e4cffd39e31dcc9e SHA512 2d0c6af4a187c8c4493060dc2f29f7408f1837714b1fe1bdcaccb805b210f90398116a6c6939d654863193f3e93830d413fe215684140ecd00c7920bd241bbde
+EBUILD wmweather+-2.18-r1.ebuild 694 BLAKE2B f3c2644261ac6cff8a34f912f123f47a175da1efc797991214578c1cfa70ee50bd0e36d39671cb32b72f5ef697e0f95f8e98778c6adff00c21e7c072e8e24b64 SHA512 d00e851d1457ecfab8cdafdf513d01ed7fdf09e6be3dba1d062e8e1df912a3bb08fb341c4a1329b58f2d5b7db4713b495761321824b20001652b399a47c19ecd
MISC metadata.xml 336 BLAKE2B 48982c1c5147d5f6ab23ef1a966d6e9af3c31a21e8c4be84a4bfafe8002b63602189db6bf10bd0e09541e34c93734c7d7bb73242ba644a10529a89f190a6ed9c SHA512 5643433185d3b17f36ed1bf03c9d40c7a2272b4ff2e7542a0e437b2be3fa9bca6e893c34f1c8c5c03afb0967aec7fcfb0e723d12878c0289314c9b3c3d0e7dfc
diff --git a/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch b/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch
new file mode 100644
index 000000000000..68a4d3f33190
--- /dev/null
+++ b/x11-plugins/wmweather+/files/wmweather+-2.18-configure-clang16.patch
@@ -0,0 +1,67 @@
+https://sourceforge.net/p/wmweatherplus/bugs/21/
+https://bugs.gentoo.org/870958
+
+Port the configure script to C99 by avoiding calls to the undeclared
+exit function. Future compilers are likely to reject implicit
+function declarations by default; this C features was removed from the
+language in 1999.
+
+--- a/m4/snprintf.m4
++++ b/m4/snprintf.m4
+@@ -24,7 +24,7 @@ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+ [[char foo[]="ABC"; snprintf(foo, 2, "%d", 12);
+-exit((foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1);]])],
++return (foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1;]])],
+ [x_cv_func_snprintf_size=yes],
+ [x_cv_func_snprintf_size=no],
+ [x_cv_func_snprintf_size=no])])
+@@ -52,7 +52,7 @@ AC_CACHE_CHECK([if snprintf return value is sane], x_cv_func_snprintf_retval,
+ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+-[[char foo[10]; exit((snprintf(foo, 1, "%d", 9876)==4)?0:1);]])],
++[[char foo[10]; return (snprintf(foo, 1, "%d", 9876)==4)?0:1;]])],
+ [x_cv_func_snprintf_retval=yes],
+ [x_cv_func_snprintf_retval=no],
+ [x_cv_func_snprintf_retval=no])])
+@@ -79,7 +79,7 @@ AC_CACHE_CHECK([if snprintf(NULL, 0, ...) works], x_cv_func_snprintf_null_ok,
+ int snprintf(char *str, size_t size, const char *format, ...);
+ #endif
+ ]],
+-[int r=snprintf(NULL, 0, "%d", 100); exit((r==3 || r==-1)?0:1);])],
++[int r=snprintf(NULL, 0, "%d", 100); return (r==3 || r==-1)?0:1;])],
+ [x_cv_func_snprintf_null_ok=yes],
+ [x_cv_func_snprintf_null_ok=no],
+ [x_cv_func_snprintf_null_ok=no])])
+--- a/m4/vsnprintf.m4
++++ b/m4/vsnprintf.m4
+@@ -37,7 +37,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ }
+ ]],
+ [[char foo[]="ABC"; doit(foo, 2, "%d", 12);
+-exit((foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1);]])],
++return (foo[0]=='1' && foo[1]=='\0' && foo[2]=='C')?0:1;]])],
+ [x_cv_func_vsnprintf_size=yes],
+ [x_cv_func_vsnprintf_size=no],
+ [x_cv_func_vsnprintf_size=no])])
+@@ -74,7 +74,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ return r;
+ }
+ ]],
+-[[char foo[10]; exit((doit(foo, 1, "%d", 9876)==4)?0:1);]])],
++[[char foo[10]; return (doit(foo, 1, "%d", 9876)==4)?0:1;]])],
+ [x_cv_func_vsnprintf_retval=yes],
+ [x_cv_func_vsnprintf_retval=no],
+ [x_cv_func_vsnprintf_retval=no])])
+@@ -110,7 +110,7 @@ int doit(char *str, size_t size, const char *format, ...){
+ return r;
+ }
+ ]],
+-[int r=doit(NULL, 0, "%d", 100); exit((r==3 || r==-1)?0:1);])],
++[int r=doit(NULL, 0, "%d", 100); return (r==3 || r==-1)?0:1;])],
+ [x_cv_func_vsnprintf_null_ok=yes],
+ [x_cv_func_vsnprintf_null_ok=no],
+ [x_cv_func_vsnprintf_null_ok=no])])
+
diff --git a/x11-plugins/wmweather+/wmweather+-2.18.ebuild b/x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild
index 3ff866178306..0c62154e0166 100644
--- a/x11-plugins/wmweather+/wmweather+-2.18.ebuild
+++ b/x11-plugins/wmweather+/wmweather+-2.18-r1.ebuild
@@ -21,7 +21,10 @@ DEPEND="dev-libs/libpcre
x11-wm/windowmaker"
RDEPEND="${DEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-ar.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-ar.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
+)
src_prepare() {
default