summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-08 06:31:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-08 06:31:00 +0100
commit102dc42fae2907037d3ca9a6d63ed28e46c5b88e (patch)
tree5302a53ecdd7408812596fcbd8cbaa90bd8e6c98 /x11-plugins
parent4d190a87291ace8503ad92c6b049d14660a14c72 (diff)
gentoo auto-resync : 08:04:2024 - 06:31:00
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26776 -> 26770 bytes
-rw-r--r--x11-plugins/vicious/Manifest2
-rw-r--r--x11-plugins/vicious/vicious-2.7.0.ebuild64
3 files changed, 66 insertions, 0 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index 12ca14c941c8..f9bbc1adc631 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index e5dcb73ff4c5..8b4cfae6b5a9 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1,3 +1,5 @@
DIST vicious-2.6.0.tar.gz 69108 BLAKE2B de86326b8975511cf053e6707bdc133ad23c95cadd64190de326bfae2c710a2f97b7cbc102cf88f14e6ebfdeface2896862b52521ba5d83a47014bc7bd65d0d3 SHA512 d8107ab1bad80b115789d7dbda44568cee17546f76c03889028f61f8293d9c897eec1cb7f96b973a39f0c94889c13f13c6cbccb944390c80820a327691223af6
+DIST vicious-2.7.0.tar.gz 69420 BLAKE2B 5de98a40e2cf0c0d02820c4bc3a6c1f349a0a2efa9b1947ff39b522fe0c58ea92e1772e16d4b798147e985dcd37b4b8c31b67f3c4d791b3d1594af5d13d6b716 SHA512 683816be5a667671ae11b7aa1f5ca718a79f03ebdde8c38a44f2648c1cfd3facea256f0cad04f963ba00766427f8196050a77ff7446ef427a31adfeb0fb6799c
EBUILD vicious-2.6.0.ebuild 2295 BLAKE2B 7857ba735a36ab909eeab12978454ab7793a49bb04fb2d6b0aad0257c764196b3fa1e6988fdf0e1d82bb612b2d6c33a899c49072ad764af78c54cb9aa9e79792 SHA512 ebd0858f7452da45d0ccf272cdb9efd5ebb8626d06126558b46d793a6d139c11a5a04c00cc70d9404c473ec6db220ff3e1ad7f1f0617a2210c23db8fc2829ebf
+EBUILD vicious-2.7.0.ebuild 2297 BLAKE2B 9674b5a73b858430c6089e9fcc4effe95e95740b6431ebbbf8667e72c40c42bb5b83b32bd39f8afb75d83cfa2d199cdb1d20af8d71667252b6bc6c24c2d95615 SHA512 1066e59459e311b13eaf7f64e2751b6a159b2bab0b5a180a620f6cd7fcdfe5652c9446c212f6b52b9382c38e4b2cff9f30ada80276364a0c989616fd743c5c5b
MISC metadata.xml 492 BLAKE2B 21caf589f9a40c2b9203b2a45a4f0b60c6ce52e78a8fec7173c1a8467cb92a4891c28e412324f5652d1fd17b3fb07780b800bac643c3476e5b2d962124f86066 SHA512 5882c4db0ceea18943171338a23ffe8b31431a63d255cac0ef3544a3a267699969f9a735b5cb30d834f053c4bd574cb5aaa45c991c1b919c986683d991aacdba
diff --git a/x11-plugins/vicious/vicious-2.7.0.ebuild b/x11-plugins/vicious/vicious-2.7.0.ebuild
new file mode 100644
index 000000000000..b76d5eb36a21
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.7.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit optfeature
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/vicious-widgets/vicious"
+SRC_URI="https://github.com/${PN}-widgets/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~riscv ~x86"
+IUSE="contrib"
+
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets spawn.lua helpers.lua init.lua
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Note that as of 2.5.1 this list may or may not be incomplete - it has been produced
+ # only by searching for occurrences of vicious.spawn (the recommended way of calling
+ # external helpers because it supports async) and popen (still used by many contrib widgets).
+ # Moreover, dependencies of all non-Linux widgets have been excluded on purpose.
+ optfeature_header "These widgets need some dependencies:"
+ optfeature "cmus" "media-sound/cmus"
+ optfeature "fs" "sys-apps/coreutils" # df
+ optfeature "gmail" "net-misc/curl"
+ optfeature "hddtemp" "net-misc/curl[telnet] app-admin/hddtemp"
+ optfeature "hwmontemp" "sys-apps/grep"
+ optfeature "mdir" "sys-apps/findutils"
+ optfeature "mpd" "net-misc/curl[telnet] media-sound/mpd"
+ optfeature "notmuch" "net-mail/notmuch"
+ optfeature "volume" "media-sound/alsa-utils" # amixer
+ optfeature "weather" "net-misc/curl"
+ optfeature "wifi" "net-wireless/wireless-tools"
+ optfeature "wifiiw" "net-wireless/iw"
+ if use contrib; then
+ optfeature "contrib/btc" "net-misc/curl"
+ optfeature "contrib/buildbot" "net-misc/curl"
+ optfeature "contrib/countfiles" "sys-apps/findutils"
+ optfeature "contrib/mpc" "media-sound/mpc"
+ optfeature "contrib/openweather" "net-misc/curl"
+ optfeature "contrib/netcfg" "sys-apps/coreutils" # ls
+ optfeature "contrib/nvinf" "x11-drivers/nvidia-drivers" # nvidia-settings
+ # ossvol needs 'ossmix' - not packaged?
+ optfeature "contrib/pulse" "media-sound/pulseaudio" # pacmd
+ optfeature "contrib/rss" "net-misc/curl"
+ optfeature "contrib/sensors" "sys-apps/lm-sensors"
+ optfeature "contrib/wpa" "net-wireless/wpa_supplicant" # wpa-cli
+ fi
+ elog
+}