summaryrefslogtreecommitdiff
path: root/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-19 23:10:29 +0100
commit318828e81fe6707ce5a64e6a59a76d4c0ca709f8 (patch)
treecc4b7818f7960cb193ad2bf7f7defe71adb3ee47 /x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
parent590c04803f88a968b4a750c0f420eb314e1fe968 (diff)
gentoo auto-resync : 19:09:2023 - 23:10:29
Diffstat (limited to 'x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild')
-rw-r--r--x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild b/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
new file mode 100644
index 000000000000..c8f8ee534cc3
--- /dev/null
+++ b/x11-plugins/wmweather/wmweather-2.4.7-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Dockable weather monitor for standard METAR stations using ICAO location"
+HOMEPAGE="https://people.debian.org/~godisch/wmweather/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libICE
+ x11-apps/xmessage
+ net-misc/curl"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=(
+ "${WORKDIR}"/${P}/CHANGES
+ "${WORKDIR}"/${P}/README
+ )
+
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-fno-common.patch
+}