summaryrefslogtreecommitdiff
path: root/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-plugins/wmtime/wmtime-1.4-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-plugins/wmtime/wmtime-1.4-r1.ebuild')
-rw-r--r--x11-plugins/wmtime/wmtime-1.4-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmtime/wmtime-1.4-r1.ebuild b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
new file mode 100644
index 000000000000..4ea44b15579c
--- /dev/null
+++ b/x11-plugins/wmtime/wmtime-1.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="applet which displays the date and time in a dockable tile"
+HOMEPAGE="https://www.dockapps.net/wmtime"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( BUGS CHANGES HINTS README TODO )
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ einstalldocs
+}