summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild')
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..d48af6dcae9a
--- /dev/null
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
+HOMEPAGE="https://github.com/bbidulock/wmsystray"
+SRC_URI="https://github.com/bbidulock/wmsystray/releases/download/${PV}/${P}.tar.bz2"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+# Let's honour Gentoo CFLAGS and use correct install program
+# Fix for #61704, cannot compile with gcc 3.4.1:
+# it's a trivial change and does not affect other compilers...
+PATCHES=( "${FILESDIR}/${P}-Makefile.patch"
+ "${FILESDIR}/${P}-gcc-3.4.patch" )
+
+DOCS=( README HACKING AUTHORS )
+
+src_prepare() {
+ default
+ # Fix parallel compilation
+ sed -ie "s/make EXTRACFLAGS/make \${MAKEOPTS} EXTRACFLAGS/" Makefile || die
+
+ # Honour Gentoo LDFLAGS, see bug #336296
+ sed -ie "s/-o wmsystray/${LDFLAGS} -o wmsystray/" wmsystray/Makefile || die
+}
+
+src_compile() {
+ emake EXTRACFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}/${PN}
+ doman doc/${PN}.1
+ domenu "${FILESDIR}/${PN}.desktop"
+ einstalldocs
+}