summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild')
-rw-r--r--x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
index 4756f31445fd..926644e2d5b7 100644
--- a/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
+++ b/x11-plugins/wmsystray/wmsystray-0.1.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit desktop
+inherit desktop toolchain-funcs
DESCRIPTION="Window Maker dock app that provides a system tray for GNOME/KDE applications"
HOMEPAGE="https://github.com/bbidulock/wmsystray"
@@ -17,11 +17,11 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc ~sparc x86"
-# Let's honour Gentoo CFLAGS and use correct install program
-# Fix for #61704, cannot compile with gcc 3.4.1:
-# it's a trivial change and does not affect other compilers...
-PATCHES=( "${FILESDIR}/${P}-Makefile.patch"
- "${FILESDIR}/${P}-gcc-3.4.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-Makefile.patch"
+ "${FILESDIR}/${P}-gcc-3.4.patch"
+ "${FILESDIR}/${P}-return-type.patch"
+)
DOCS=( README HACKING AUTHORS )
@@ -35,7 +35,7 @@ src_prepare() {
}
src_compile() {
- emake EXTRACFLAGS="${CFLAGS}"
+ emake CC="$(tc-getCC)" EXTRACFLAGS="${CFLAGS}"
}
src_install() {