summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsystray/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /x11-plugins/wmsystray/files
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'x11-plugins/wmsystray/files')
-rw-r--r--x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch30
-rw-r--r--x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch12
2 files changed, 31 insertions, 11 deletions
diff --git a/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch b/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
index 19afa355b229..ab754703962b 100644
--- a/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
+++ b/x11-plugins/wmsystray/files/wmsystray-0.1.1-Makefile.patch
@@ -1,6 +1,6 @@
-diff -ur wmsystray-0.1.1/Makefile wmsystray-0.1.1.new/Makefile
---- wmsystray-0.1.1/Makefile 2004-03-01 05:35:47.000000000 +0100
-+++ wmsystray-0.1.1.new/Makefile 2007-06-30 18:09:59.000000000 +0200
+diff -Naur wmsystray-0.1.1.orig/Makefile wmsystray-0.1.1/Makefile
+--- wmsystray-0.1.1.orig/Makefile 2004-03-01 05:35:47.000000000 +0100
++++ wmsystray-0.1.1/Makefile 2020-12-03 11:22:13.786357942 +0100
@@ -1,13 +1,14 @@
prefix=/usr
bindir = ${prefix}/bin
@@ -19,21 +19,29 @@ diff -ur wmsystray-0.1.1/Makefile wmsystray-0.1.1.new/Makefile
clean:
make -C xembed clean
-diff -ur wmsystray-0.1.1/wmsystray/Makefile wmsystray-0.1.1.new/wmsystray/Makefile
---- wmsystray-0.1.1/wmsystray/Makefile 2004-03-01 04:54:44.000000000 +0100
-+++ wmsystray-0.1.1.new/wmsystray/Makefile 2007-06-30 18:09:59.000000000 +0200
-@@ -1,7 +1,7 @@
+diff -Naur wmsystray-0.1.1.orig/wmsystray/Makefile wmsystray-0.1.1/wmsystray/Makefile
+--- wmsystray-0.1.1.orig/wmsystray/Makefile 2004-03-01 04:54:44.000000000 +0100
++++ wmsystray-0.1.1/wmsystray/Makefile 2020-12-03 11:26:57.544595661 +0100
+@@ -1,14 +1,13 @@
include ../Rules.make
- CC = gcc
+-CC = gcc
-CFLAGS = ${X11CFLAGS} -DTRACE_LEVEL=${TRACE_LEVEL} -I../xembed -Wall -g
+CFLAGS = ${X11CFLAGS} -DTRACE_LEVEL=${TRACE_LEVEL} -I../xembed -g ${EXTRACFLAGS}
LDFLAGS = ${X11LDFLAGS} -lXpm
OBJS = main.o ui.o systray.o xpms.o
-diff -ur wmsystray-0.1.1/xembed/Makefile wmsystray-0.1.1.new/xembed/Makefile
---- wmsystray-0.1.1/xembed/Makefile 2004-03-01 04:54:44.000000000 +0100
-+++ wmsystray-0.1.1.new/xembed/Makefile 2007-06-30 18:09:59.000000000 +0200
+ XEMBED_OBJS = ../xembed/xembed.o
+
+ wmsystray: ${OBJS} ${XEMBED_OBJS}
+- gcc ${OBJS} ${XEMBED_OBJS} -o wmsystray ${LDFLAGS}
++ ${CC} ${OBJS} ${XEMBED_OBJS} -o wmsystray ${LDFLAGS}
+
+ clean:
+ rm -f wmsystray ${OBJS}
+diff -Naur wmsystray-0.1.1.orig/xembed/Makefile wmsystray-0.1.1/xembed/Makefile
+--- wmsystray-0.1.1.orig/xembed/Makefile 2004-03-01 04:54:44.000000000 +0100
++++ wmsystray-0.1.1/xembed/Makefile 2020-12-03 11:22:13.786357942 +0100
@@ -1,6 +1,6 @@
include ../Rules.make
diff --git a/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch b/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch
new file mode 100644
index 000000000000..aa2c6539b81b
--- /dev/null
+++ b/x11-plugins/wmsystray/files/wmsystray-0.1.1-return-type.patch
@@ -0,0 +1,12 @@
+diff -Naur wmsystray-0.1.1.orig/wmsystray/systray.c wmsystray-0.1.1/wmsystray/systray.c
+--- wmsystray-0.1.1.orig/wmsystray/systray.c 2004-03-01 04:54:50.000000000 +0100
++++ wmsystray-0.1.1/wmsystray/systray.c 2020-12-03 11:30:36.661776579 +0100
+@@ -338,7 +338,7 @@
+ XReparentWindow (main_disp, embed_wind,
+ DefaultRootWindow(main_disp), 0, 0);
+ TRACE((stderr, "REJECTED!\n"));
+- return;
++ return 1;
+ }
+
+ XSelectInput (main_disp, embed_wind, StructureNotifyMask |