summaryrefslogtreecommitdiff
path: root/x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild')
-rw-r--r--x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild b/x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild
new file mode 100644
index 000000000000..bb315561556d
--- /dev/null
+++ b/x11-plugins/wmsvencd/wmsvencd-0.5.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit eutils
+
+DESCRIPTION="Window Maker Dockable CD-Player with CDDB"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+DEPEND="
+ x11-wm/windowmaker
+ x11-libs/libXpm"
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ~ppc"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/wmsvencd-compile.patch
+
+ sed -i 's:c++ -o:c++ $(LDFLAGS) -o:' Makefile
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -fno-strength-reduce" || die "make failed"
+}
+
+src_install() {
+ newman wmsvencd.1x wmsvencd.1
+ dobin wmsvencd
+ dodoc README
+
+ domenu "${FILESDIR}"/${PN}.desktop
+}