summaryrefslogtreecommitdiff
path: root/x11-plugins/wmping/wmping-0.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-plugins/wmping/wmping-0.2.1-r1.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-plugins/wmping/wmping-0.2.1-r1.ebuild')
-rw-r--r--x11-plugins/wmping/wmping-0.2.1-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-plugins/wmping/wmping-0.2.1-r1.ebuild b/x11-plugins/wmping/wmping-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..ab211f81e7b3
--- /dev/null
+++ b/x11-plugins/wmping/wmping-0.2.1-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="a simple host status monitoring dockapp"
+HOMEPAGE="https://sourceforge.net/projects/wmping"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+suid"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libICE
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}"/${P}-format-security.patch )
+
+DOCS=( AUTHORS CHANGES README )
+
+src_install() {
+ if use suid; then
+ default
+ else
+ dosbin ${PN}
+ einstalldocs
+ fi
+ doman ${PN}.1
+}
+
+pkg_postinst() {
+ use suid || ewarn "warning, ${PN} needs to be executed as root."
+}