summaryrefslogtreecommitdiff
path: root/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmifinfo/wmifinfo-0.10.ebuild')
-rw-r--r--x11-plugins/wmifinfo/wmifinfo-0.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild b/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
new file mode 100644
index 000000000000..e7d5b4361859
--- /dev/null
+++ b/x11-plugins/wmifinfo/wmifinfo-0.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="a dockapp for monitoring network interfaces"
+HOMEPAGE="http://www.dockapps.net/wmifinfo"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/dockapps
+
+src_compile() {
+ emake CC="$(tc-getCC)" LD="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ dodoc README Changelog
+}