summaryrefslogtreecommitdiff
path: root/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild')
-rw-r--r--x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
new file mode 100644
index 000000000000..1c59b3de60d7
--- /dev/null
+++ b/x11-plugins/wmgrabimage/wmgrabimage-0.72-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop
+
+MY_PN=${PN/grabi/GrabI}
+
+DESCRIPTION="wmGrabImage grabs an image from the WWW and displays it"
+HOMEPAGE="https://www.dockapps.net/wmgrabimage"
+SRC_URI="https://www.dockapps.net/download/${MY_PN}-${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=net-misc/wget-1.9-r2
+ >=media-gfx/imagemagick-5.5.7.15
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+S=${WORKDIR}/${MY_PN}-${PV}/${MY_PN}
+
+PATCHES=( "${FILESDIR}"/${PN}-noman.patch )
+
+src_prepare() {
+ sed -i -e 's/-geom /-geometry /' GrabImage || die "sed failed."
+ sed -i -e 's/install -s -m /install -m /' Makefile || die "sed failed."
+ default
+}
+
+src_compile() {
+ emake clean
+ emake CFLAGS="${CFLAGS} -Wall" SYSTEM="${LDFLAGS}"
+}
+
+src_install() {
+ dodir /usr/bin
+ emake DESTDIR="${D}/usr" install
+
+ doman wmGrabImage.1
+ domenu "${FILESDIR}"/${PN}.desktop
+ dodoc ../{BUGS,CHANGES,HINTS,TODO}
+}