summaryrefslogtreecommitdiff
path: root/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild')
-rw-r--r--x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild b/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
new file mode 100644
index 000000000000..ad134fe8a64d
--- /dev/null
+++ b/x11-plugins/wmfrog/wmfrog-0.2.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="a weather application, it shows the weather in a graphical way"
+HOMEPAGE="http://wiki.colar.net/wmfrog_dockapp"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libXpm
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S=${WORKDIR}/Src
+
+src_prepare() {
+ epatch "${FILESDIR}"/*-${PV}.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" INCDIR="" \
+ LIBDIR="" SYSTEM="${LDFLAGS}" || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ../{CHANGES,HINTS}
+}