summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcube
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-plugins/wmcube
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-plugins/wmcube')
-rw-r--r--x11-plugins/wmcube/Manifest3
-rw-r--r--x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch21
-rw-r--r--x11-plugins/wmcube/wmcube-1.0.2.ebuild9
3 files changed, 31 insertions, 2 deletions
diff --git a/x11-plugins/wmcube/Manifest b/x11-plugins/wmcube/Manifest
index 629f59f878e7..a0084e08f9eb 100644
--- a/x11-plugins/wmcube/Manifest
+++ b/x11-plugins/wmcube/Manifest
@@ -1,3 +1,4 @@
+AUX wmcube-1.0.2-gcc-10.patch 460 BLAKE2B 4335f8a0f332efd800c8909d047146304f995d3193648e305b8d0def050581222b8f5676bfcb8125d0d3f0cb1d6de69fe287b3cd12ccb850da1ba8a53c51d420 SHA512 23be30779c7cd4d9d28af8998adb9e13c4e8fb4fa417c5bec06a8dc12d9587fabdc31a10f56d474d005c577a83a1745a47fbe155ca9164b4dd5b9e4e5496f133
DIST wmcube-1.0.2.tar.gz 56908 BLAKE2B 4ce373b3822e9d515d611e577214a2c51a8e4fb62cc47cf9f64ad49441bd3c53ba09d301c898a37f6ffafecf984ae04cefce9890c593797719b29fb54425f6c7 SHA512 171700848a9d674ced3ee33468b967b2be706e72863f8356f0d8d72785c06a1c34b5be3597e5604bf74e97ee911ca05b68a28bfe67c1171a61c7084450d622de
-EBUILD wmcube-1.0.2.ebuild 894 BLAKE2B c776ddfde122bb52f2d0dfdaf7ebfcb52a1d7abab2a620bca51d85c933adab3ca646adf8c1f49f8364dfd25ff980f931a63cf6a57671aa80a54cf95a85c99ce9 SHA512 cac0eca56de0a8384cac8299a3fd9f1c4ee4c4ccd1f5a657dbf66570306117babb2defb45b64d85e90b8cb753b706b45af8f729c16beaa1a8e1259f0698b26a8
+EBUILD wmcube-1.0.2.ebuild 995 BLAKE2B 905bdc025c9ff1a33be32f2f2696bdc7ba18384c62955cc108170f66c70fdcd1987b70971edbadcc77b3f5d6c438a487f3f239527ea17476b7ce1f82a261bbfc SHA512 e198d696917c677ec4dd252f3da976d98ee44c96a3354be9e7aa838c59f745f94d34d68afa89b45ee6cbba4ac80dbf283969e4c1e7d2f5ee779220a7f046c5ea
MISC metadata.xml 417 BLAKE2B 7d594431bb0c67d7275c73e53e6958ff415beaf1ec79b82bbf887b3ac16d17e13e8319f467c17bd376b04130959767be65e6112bd7032b853502b8d9dd07817e SHA512 370036b0e1a6a62c3251f22f687277a6ad684b02e423db1b2879fc08267db8c4b6de7e0e35de500b836dd1156d717bf3100e3de4027477473e30aeb1adf339ba
diff --git a/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch b/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch
new file mode 100644
index 000000000000..5beb41552562
--- /dev/null
+++ b/x11-plugins/wmcube/files/wmcube-1.0.2-gcc-10.patch
@@ -0,0 +1,21 @@
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -45,6 +45,7 @@ Window iconwin, win;
+ GC NormalGC;
+ XpmIcon wmgen;
+ Pixmap pixmask;
++Display *display;
+
+ /*****************/
+ /* Mouse Regions */
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -21,7 +21,7 @@ typedef struct {
+ /* Global variable */
+ /*******************/
+
+-Display *display;
++extern Display *display;
+
+ /***********************/
+ /* Function Prototypes */
diff --git a/x11-plugins/wmcube/wmcube-1.0.2.ebuild b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
index cca916b659af..1a9633dc99cc 100644
--- a/x11-plugins/wmcube/wmcube-1.0.2.ebuild
+++ b/x11-plugins/wmcube/wmcube-1.0.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -26,6 +26,13 @@ DOCS=(
)
S="${WORKDIR}/${P}/wmcube"
+src_prepare() {
+ default
+
+ pushd "${WORKDIR}"/${P} || die
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
+}
+
src_compile() {
emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}