summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild')
-rw-r--r--x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild b/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
new file mode 100644
index 000000000000..70c2fcf3f058
--- /dev/null
+++ b/x11-plugins/wmcms/wmcms-0.3.5-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WindowMaker CPU and Memory Usage Monitor Dock App"
+HOMEPAGE="https://www.geocities.ws/neofpo/wmcms.html"
+SRC_URI="https://www.geocities.ws/neofpo/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+
+PATCHES=(
+ "${FILESDIR}"/${P}-s4t4n.patch
+)
+
+src_prepare() {
+ default
+
+ # Respect LDFLAGS, see bug #335031
+ sed -e 's/ -o wmcms/ ${LDFLAGS} -o wmcms/' -i Makefile || die
+
+ sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i *.c || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin wmcms
+}