summaryrefslogtreecommitdiff
path: root/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'x11-plugins/wmbiff/wmbiff-0.4.36.ebuild')
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.36.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
new file mode 100644
index 000000000000..440e743d6035
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.36.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="https://www.dockapps.net/wmbiff"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ )
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}