summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild')
-rw-r--r--x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild
new file mode 100644
index 000000000000..629bb47cf961
--- /dev/null
+++ b/x11-plugins/wmacpiload-ac/wmacpiload-ac-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+MY_P=${P/-ac}
+DESCRIPTION="WMACPILoad based dockapp to monitor CPU temp and battery time on ACPI kernels"
+HOMEPAGE="http://wmacpiload.tuxfamily.org/"
+SRC_URI="http://wmacpiload.tuxfamily.org/download/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 x86"
+IUSE="debug"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ econf $(use_enable debug)
+ emake || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}