summaryrefslogtreecommitdiff
path: root/x11-plugins/wmacpi/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /x11-plugins/wmacpi/files
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'x11-plugins/wmacpi/files')
-rw-r--r--x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch b/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch
new file mode 100644
index 000000000000..d772c99b6ed4
--- /dev/null
+++ b/x11-plugins/wmacpi/files/wmacpi-2.4-makefile.patch
@@ -0,0 +1,48 @@
+diff -Naur wmacpi-2.4.orig/Makefile wmacpi-2.4/Makefile
+--- wmacpi-2.4.orig/Makefile 2020-05-03 14:30:36.000000000 +0200
++++ wmacpi-2.4/Makefile 2020-06-15 17:32:49.549006100 +0200
+@@ -15,8 +15,8 @@
+ #OPT = -pg -g
+
+ CC := gcc
+-CFLAGS += $(OPT) -Wall -W -g -ansi -DWMACPI_VER='"$(WMACPI_VER)"'
+-LDFLAGS += $(OPT) -lX11 -ldockapp
++CFLAGS += -DWMACPI_VER='"$(WMACPI_VER)"'
++LIBS := -lX11 -ldockapp
+
+ WMSRC := wmacpi.c libacpi.c
+ HEADERS := libacpi.h
+@@ -28,7 +28,7 @@
+ doc_targets += wmacpi-cli.1
+ endif
+
+-PREFIX := /usr/local
++PREFIX := /usr
+
+ all: $(targets)
+
+@@ -39,7 +39,7 @@
+ -include $(WMOBJ:.o=.d)
+
+ wmacpi: $(WMOBJ)
+- $(CC) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+
+ # for the Debian package, we want to make building the command line tools
+ # optional. So, we hide all the necessary stuff here . . .
+@@ -49,13 +49,13 @@
+ -include $(CLOBJ:.o=.d)
+
+ wmacpi-cli: $(CLOBJ)
+- $(CC) $(LDFLAGS) -o $@ $^
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+ endif
+
+ # build per-file dependencies - note that -MM may not be supported
+ # in gcc versions older than 2.95.4, but most likely is.
+ %.d: %.c
+- gcc -MM $(CFLAGS) $< > $@
++ $(CC) -MM $(CFLAGS) $< > $@
+
+ clean:
+ rm -f TAGS *.o *~ trace *.out *.bb *.bbg