summaryrefslogtreecommitdiff
path: root/x11-plugins/wmSun/wmSun-1.05.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmSun/wmSun-1.05.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmSun/wmSun-1.05.ebuild')
-rw-r--r--x11-plugins/wmSun/wmSun-1.05.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmSun/wmSun-1.05.ebuild b/x11-plugins/wmSun/wmSun-1.05.ebuild
new file mode 100644
index 000000000000..339a3b82f1f7
--- /dev/null
+++ b/x11-plugins/wmSun/wmSun-1.05.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+MY_P=${P/S/s}
+DESCRIPTION="dockapp which displays the rise/set time of the sun"
+HOMEPAGE="http://www.dockapps.net/wmsun"
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~mips ~ppc sparc x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/libdockapp-0.7:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+ dodoc README {BUGS,TODO}
+}