summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild')
-rw-r--r--x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild b/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild
new file mode 100644
index 000000000000..38840750300e
--- /dev/null
+++ b/x11-plugins/pidgin-gpg/pidgin-gpg-0.9.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin GPG/OpenPGP (XEP-0027) plugin"
+HOMEPAGE="https://github.com/Draghtnod/Pidgin-GPG"
+SRC_URI="https://github.com/Draghtnod/Pidgin-GPG/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-crypt/gpgme
+ net-im/pidgin"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/Pidgin-GPG-${PV}"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}