summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-gnome-keyring/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-plugins/pidgin-gnome-keyring/files
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-plugins/pidgin-gnome-keyring/files')
-rw-r--r--x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch32
-rw-r--r--x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch6
2 files changed, 35 insertions, 3 deletions
diff --git a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch
new file mode 100644
index 000000000000..4f33cee65318
--- /dev/null
+++ b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-pkgconfig_dirs.patch
@@ -0,0 +1,32 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,10 +1,11 @@
+ TARGET = gnome-keyring
+
+-SECRETFLAGS = `pkg-config --libs --cflags libsecret-1`
+-PURPLEFLAGS = `pkg-config --cflags purple`
+-VERSION = $(shell cat VERSION)
++SECRETFLAGS := $(shell pkg-config --libs --cflags libsecret-1)
++PURPLEFLAGS := $(shell pkg-config --cflags purple)
++PLUGINDIR := $(shell pkg-config --variable=plugindir purple)
++VERSION := $(shell cat VERSION)
+ ifeq ($(strip $(VERSION)),)
+- VERSION = `git describe --tags`
++ VERSION := $(shell git describe --tags)
+ endif
+
+ all: ${TARGET}.so
+@@ -15,11 +16,10 @@
+
+ ${TARGET}.so: ${TARGET}.c
+
+- ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. -g -O2 ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC -ggdb ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
++ ${CC} ${CFLAGS} ${LDFLAGS} -Wall -I. ${TARGET}.c -o ${TARGET}.so -shared -fPIC -DPIC ${PURPLEFLAGS} ${SECRETFLAGS} -DVERSION=\"${VERSION}\"
+
+ install: ${TARGET}.so
+- mkdir -p ${DESTDIR}/usr/lib/purple-2/
+- cp ${TARGET}.so ${DESTDIR}/usr/lib/purple-2/
++ install -D ${TARGET}.so ${DESTDIR}/$(PLUGINDIR)/${TARGET}.so
+
+ install_local: ${TARGET}.so
+ mkdir -p ~/.purple/plugins
diff --git a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
index 6aa6ffca3c52..a96080fc6aa3 100644
--- a/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
+++ b/x11-plugins/pidgin-gnome-keyring/files/pidgin-gnome-keyring-2.0-plugindir.patch
@@ -1,10 +1,10 @@
---- a/Makefile 2015-02-07 03:23:05.000000000 +0000
-+++ b/Makefile 2016-04-28 09:53:59.915565380 +0000
+--- a/Makefile
++++ b/Makefile
@@ -2,6 +2,7 @@
SECRETFLAGS = `pkg-config --libs --cflags libsecret-1`
PURPLEFLAGS = `pkg-config --cflags purple`
-+PLUGINDIR = `pkg-config --variable=plugindir purple`
++PLUGINDIR = `${PKG_CONFIG} --variable=plugindir purple`
VERSION = $(shell cat VERSION)
ifeq ($(strip $(VERSION)),)
VERSION = `git describe --tags`