summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild')
-rw-r--r--x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
new file mode 100644
index 000000000000..848cafaec1f4
--- /dev/null
+++ b/x11-plugins/pidgin-bot-sentry/pidgin-bot-sentry-1.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="3"
+
+inherit eutils multilib
+
+MY_P="${P#pidgin-}"
+DESCRIPTION="Bot Sentry is a Pidgin plugin to prevent Instant Message (IM) spam"
+HOMEPAGE="http://pidgin-bs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pidgin-bs/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin[gtk]
+ x11-libs/gtk+:2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}