summaryrefslogtreecommitdiff
path: root/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild')
-rw-r--r--x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
new file mode 100644
index 000000000000..8b2365c21a5b
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Plugin for Pidgin that reminds you of your buddies birthdays"
+HOMEPAGE="https://launchpad.net/pidgin-birthday-reminder"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs"
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+ fi
+}