summaryrefslogtreecommitdiff
path: root/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild')
-rw-r--r--x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild b/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
new file mode 100644
index 000000000000..5bdff0ee4969
--- /dev/null
+++ b/x11-plugins/i8krellm/i8krellm-2.5-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="GKrellM2 Plugin for the Dell Inspiron and Latitude notebooks"
+SRC_URI="http://www.coding-zone.com/${P}.tar.gz"
+HOMEPAGE="http://www.coding-zone.com/?page=i8krellm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ >=app-laptop/i8kutils-1.5"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-Respect-LDFLAGS.patch
+ "${FILESDIR}"/${P}-r3-makefile-fixes.patch
+ "${FILESDIR}"/${P}-r3-rm-gkrellm1-support.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)"
+}