summaryrefslogtreecommitdiff
path: root/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild')
-rw-r--r--x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
new file mode 100644
index 000000000000..65978b6b7f10
--- /dev/null
+++ b/x11-plugins/hexchat-javascript/hexchat-javascript-0.3.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="Javascript interface for HexChat"
+HOMEPAGE="https://github.com/TingPing/hexchat-javascript"
+SRC_URI="https://github.com/TingPing/hexchat-javascript/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="
+ dev-lang/spidermonkey:0
+ >=net-irc/hexchat-2.9.6[plugins(+)]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != binary ]]; then
+ tc-export CXX PKG_CONFIG
+ fi
+}
+
+src_install() {
+ dodir /usr/share/appdata
+ default
+ if use examples ; then
+ dodoc -r examples
+ fi
+}