summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrelltop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /x11-plugins/gkrelltop/files
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'x11-plugins/gkrelltop/files')
-rw-r--r--x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch41
1 files changed, 41 insertions, 0 deletions
diff --git a/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch b/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch
new file mode 100644
index 000000000000..9eaa9cc3d4e8
--- /dev/null
+++ b/x11-plugins/gkrelltop/files/gkrelltop-2.2.13-fix-build-system.patch
@@ -0,0 +1,41 @@
+--- a/Makefile
++++ b/Makefile
+@@ -45,11 +45,10 @@
+ # Parameters for gkrellm version 2.*
+ CFLAGS2 = -g -D$(OSFLAG) -DGKRELLM2 -fPIC -Wall `pkg-config gtk+-2.0 --cflags`
+ LIBS =
+-CC=/usr/bin/gcc $(CFLAGS2)
++CC += $(CFLAGS) $(CFLAGS2)
+
+ else
+ # Parameters for gkrellm version 1.*
+-CC=/usr/bin/cc
+ CFLAGS = -D$(OSFLAG) -Wall -fPIC `gtk-config --cflags` `imlib-config --cflags-gdk`
+ LIBS=
+
+@@ -78,7 +77,7 @@
+ ifeq ($(INSTALLDIRD),)
+ INSTALLDIRD=$(HOME)/.gkrellm2/plugins-gkrellmd
+ endif
+-CCD=/usr/bin/gcc $(CFLAGSD)
++CCD = $(CC) $(CFLAGS) $(CFLAGSD)
+ OBJD = gkrelltopd.o top_three.o
+
+ DUMMY_VAR := $(shell ./configure $(CONFIGURE_ARGS))
+@@ -100,14 +99,14 @@
+ warn: ; $(WARN)
+
+ $(GKRELLTOP): $(OBJ) warn
+- $(CC) -shared $(OBJ) -o $(GKRELLTOP)
++ $(CC) $(LDFLAGS) -shared $(OBJ) -o $(GKRELLTOP)
+
+ # Compile gkrelltopd.so server plugin
+ server: $(GKRELLTOPD) warn
+ @echo ""
+
+ $(GKRELLTOPD): $(OBJD)
+- $(CCD) $(LIBSD) -shared $(OBJD) -o $(GKRELLTOPD)
++ $(CCD) $(LIBSD) $(LDFLAGS) -shared $(OBJD) -o $(GKRELLTOPD)
+
+ gkrelltop.o: gkrelltop.c
+ $(CC) -c gkrelltop.c -o gkrelltop.o