summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-05 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-05 03:04:53 +0000
commit94393d04ccce851b0084c650c99a2eca52f9d3bb (patch)
tree1da77141f18141b486ecd360d46c5988962c7653 /x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild
parentc4d92ab721dfc646b4a58429d965e9446294ce26 (diff)
gentoo auto-resync : 05:12:2022 - 03:04:53
Diffstat (limited to 'x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild')
-rw-r--r--x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild
new file mode 100644
index 000000000000..d452d63895c9
--- /dev/null
+++ b/x11-plugins/gkrellshoot/gkrellshoot-0.4.4-r5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="GKrellm2 plugin to take screen shots and lock screen"
+HOMEPAGE="http://gkrellshoot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gkrellshoot/${P}.tar.gz"
+S="${WORKDIR}/${P/s/S}"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="app-admin/gkrellm:2[X]"
+RDEPEND="
+ ${DEPEND}
+ virtual/imagemagick-tools"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/makefile-respect-flags.patch
+ "${FILESDIR}/${P}"-r4-pkgconfig.patch
+ "${FILESDIR}/${P}"-r5-fix-implicit-int.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ default
+}