summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild')
-rw-r--r--x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
new file mode 100644
index 000000000000..7cd6220fe5a7
--- /dev/null
+++ b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Configurable Tray Icons for GKrellM"
+HOMEPAGE="http://gkrellm.srcbox.net/Plugins.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_configure() {
+ PLUGIN_SO=( trayicons$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}