summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellm-imonc/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/gkrellm-imonc/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/gkrellm-imonc/files')
-rw-r--r--x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
new file mode 100644
index 000000000000..598e5d8460c7
--- /dev/null
+++ b/x11-plugins/gkrellm-imonc/files/gkrellm-imonc-makefile.patch
@@ -0,0 +1,35 @@
+--- a/Makefile 2003-05-17 20:08:29.000000000 +0200
++++ b/Makefile 2013-03-13 18:24:24.552941672 +0100
+@@ -9,12 +9,10 @@
+ GTK_INCLUDE = $(shell pkg-config gtk+-2.0 --cflags)
+ GTK_LIB = $(shell pkg-config gtk+-2.0 --libs)
+
+-FLAGS = -O2 -Wall -fPIC $(GTK_INCLUDE)
++FLAGS = -fPIC $(GTK_INCLUDE)
+ LIBS = $(GTK_LIB)
+
+-LFLAGS = -shared
+-
+-CC = gcc
++LFLAGS = -shared
+
+ #
+ # files
+@@ -30,7 +28,7 @@
+
+
+ %.o : %.c
+- $(CC) $(CFLAGS) $(FLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) $(FLAGS) -c $< -o $@
+
+
+ all:
+@@ -41,7 +39,7 @@
+
+ $(TARGET): $(OBJECTS)
+ @echo -e "\n\n>> linking\n"
+- $(CC) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJECTS) -o $@ $(LFLAGS) $(LIBS)
+ @echo -e "\n<< done "
+
+ install: gkrellm-imonc.so