summaryrefslogtreecommitdiff
path: root/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-04 18:55:01 +0000
commit423d21dcfee183cc4b04d29c1621615e8c30f834 (patch)
tree23bd6110b9a77b8d679b5ab60fb7663b8627f698 /x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
parent81e4fbcb846ed1cabdad699c0029b166dd7273b7 (diff)
gentoo resync : 04.01.2018
Diffstat (limited to 'x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild')
-rw-r--r--x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
index ae3ad974d5de..bbb98a017154 100644
--- a/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
+++ b/x11-plugins/gkrellkam/gkrellkam-2.0.0.ebuild
@@ -1,35 +1,36 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
-inherit eutils gkrellm-plugin toolchain-funcs
+EAPI=6
+
+inherit gkrellm-plugin toolchain-funcs
MY_P=${P/-/_}
DESCRIPTION="an Image-Watcher-Plugin for GKrellM2"
SRC_URI="mirror://sourceforge/gkrellkam/${MY_P}.tar.gz"
HOMEPAGE="http://gkrellkam.sourceforge.net"
+
LICENSE="GPL-2"
SLOT="0"
-IUSE=""
KEYWORDS="x86 ppc sparc alpha amd64"
+IUSE=""
-RDEPEND="net-misc/wget
- app-admin/gkrellm[X]"
+RDEPEND="
+ app-admin/gkrellm:2[X]
+ net-misc/wget"
DEPEND="${RDEPEND}"
-PLUGIN_SO=gkrellkam2.so
-PLUGIN_DOCS="example.list"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-makefile.patch
-}
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_compile() {
emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
}
-src_install () {
+src_install() {
+ local PLUGIN_SO=( ${PN}2$(get_modname) )
+ local PLUGIN_DOCS=( example.list )
+
gkrellm-plugin_src_install
doman gkrellkam-list.5
}