summaryrefslogtreecommitdiff
path: root/x11-plugins/fsviewer/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/fsviewer/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/fsviewer/files')
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch21
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch62
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch11
-rw-r--r--x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch36
4 files changed, 130 insertions, 0 deletions
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
new file mode 100644
index 000000000000..2d1759fefce5
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-configure.patch
@@ -0,0 +1,21 @@
+--- fsviewer-app-0.2.6.orig/configure.ac 2007-10-13 23:54:47.000000000 +0200
++++ fsviewer-app-0.2.6/configure.ac 2015-09-02 21:10:40.829519545 +0200
+@@ -26,15 +26,15 @@
+ dnl look for X windows first so further libs check
+ AC_PATH_X
+
+-if test "$x_includes" != "NONE"; then
++if test "$x_includes" != "NONE" && test -n "$x_includes"; then
+ CFLAGS="$CFLAGS -I$x_includes"
+ fi
+-if test "$x_libraries" != "NONE"; then
++if test "$x_libraries" != "NONE" && test -n "$x_libraries"; then
+ LDFLAGS="$LDFLAGS -L$x_libraries"
+ fi
+
+ dnl Additional "default" items
+-#LIBS="$LIBS -lX11"
++LIBS="$LIBS -lm -lX11 -lXpm"
+ #CFLAGS="$CFLAGS -I/usr/X11/include"
+ #LDFLAGS="$LDFLAGS -L/usr/X11/lib"
+
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch
new file mode 100644
index 000000000000..36f595609375
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-fix_title_bar.patch
@@ -0,0 +1,62 @@
+diff -Naur fsviewer-app-0.2.6.orig/src/FSFileView.c fsviewer-app-0.2.6/src/FSFileView.c
+--- fsviewer-app-0.2.6.orig/src/FSFileView.c 2007-10-14 21:06:02.000000000 +0200
++++ fsviewer-app-0.2.6/src/FSFileView.c 2015-09-02 21:18:39.574691303 +0200
+@@ -430,7 +430,7 @@
+ WMResizableWindowMask);
+ attributes.window_level = WMNormalWindowLevel;
+ attributes.extra_flags = GSFullKeyboardEventsFlag;
+- attributes.flags = (GSWindowStyleAttr | GSWindowLevelAttr |
++ attributes.flags = (/*GSWindowStyleAttr |*/ GSWindowLevelAttr |
+ GSExtraFlagsAttr);
+ WMSetWindowAttributes(fView->dpy, WMWidgetXID(fView->fileView),
+ &attributes);
+diff -Naur fsviewer-app-0.2.6.orig/src/FSFinder.c fsviewer-app-0.2.6/src/FSFinder.c
+--- fsviewer-app-0.2.6.orig/src/FSFinder.c 2006-07-23 09:24:16.000000000 +0200
++++ fsviewer-app-0.2.6/src/FSFinder.c 2015-09-02 21:18:39.574691303 +0200
+@@ -144,7 +144,7 @@
+ WMResizableWindowMask);
+ attributes.window_level = WMNormalWindowLevel;
+ attributes.extra_flags = GSFullKeyboardEventsFlag;
+- attributes.flags = (GSWindowStyleAttr | GSWindowLevelAttr |
++ attributes.flags = (/*GSWindowStyleAttr |*/ GSWindowLevelAttr |
+ GSExtraFlagsAttr);
+ WMSetWindowAttributes(finder->dpy, WMWidgetXID(finder->win),
+ &attributes);
+diff -Naur fsviewer-app-0.2.6.orig/src/FSViewer.c fsviewer-app-0.2.6/src/FSViewer.c
+--- fsviewer-app-0.2.6.orig/src/FSViewer.c 2007-10-14 17:29:04.000000000 +0200
++++ fsviewer-app-0.2.6/src/FSViewer.c 2015-09-02 21:18:39.574691303 +0200
+@@ -161,7 +161,7 @@
+ attributes.window_level = WMFloatingWindowLevel;
+ attributes.extra_flags = GSFullKeyboardEventsFlag;
+ attributes.flags =
+- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
++ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
+ WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
+ WMAppAddWindow(fsViewer->wmContext, window);
+
+@@ -189,7 +189,7 @@
+ attributes.window_level = WMNormalWindowLevel;
+ attributes.extra_flags = GSFullKeyboardEventsFlag;
+ attributes.flags =
+- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
++ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
+ WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
+ WMAppAddWindow(fsViewer->wmContext, window);
+ }
+@@ -216,7 +216,7 @@
+ attributes.window_level = WMFloatingWindowLevel;
+ attributes.extra_flags = GSFullKeyboardEventsFlag;
+ attributes.flags =
+- (GSWindowStyleAttr | GSWindowLevelAttr | GSExtraFlagsAttr);
++ (/*GSWindowStyleAttr |*/ GSWindowLevelAttr | GSExtraFlagsAttr);
+ WMSetWindowAttributes(fsViewer->dpy, window, &attributes);
+ WMAppAddWindow(fsViewer->wmContext, window);
+ }
+@@ -476,6 +476,7 @@
+ bindtextdomain("FSViewer", getenv("NLSPATH"));
+ else
+ bindtextdomain("FSViewer", LOCALEDIR);
++ bind_textdomain_codeset("FSViewer", "UTF-8");
+ textdomain("FSViewer");
+
+ if (!XSupportsLocale()) {
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
new file mode 100644
index 000000000000..2a532625ff8c
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-gcc5.patch
@@ -0,0 +1,11 @@
+--- fsviewer-app-0.2.6.orig/src/list.h
++++ fsviewer-app-0.2.6/src/list.h
+@@ -29,7 +29,7 @@
+ #ifndef __LIST_H_
+ #define __LIST_H_
+
+-#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
++#if defined(__GNUC__) && !defined(__STRICT_ANSI__) && (__GNUC__ < 5)
+ # define INLINE inline
+ #else
+ # define INLINE
diff --git a/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
new file mode 100644
index 000000000000..da64f3a0389e
--- /dev/null
+++ b/x11-plugins/fsviewer/files/fsviewer-0.2.6-wmaker-0.95_support.patch
@@ -0,0 +1,36 @@
+diff -Naur fsviewer-app-0.2.6.orig/configure.ac fsviewer-app-0.2.6/configure.ac
+--- fsviewer-app-0.2.6.orig/configure.ac 2012-07-11 17:55:06.448981246 +0200
++++ fsviewer-app-0.2.6/configure.ac 2012-07-11 18:04:15.528940159 +0200
+@@ -81,6 +81,8 @@
+ AC_MSG_ERROR([WMaker library not found]))
+ AC_CHECK_LIB(WINGs, WMAppSetMainMenu,,
+ AC_MSG_ERROR([WINGs library not found]))
++AC_CHECK_LIB(WUtil, WMCreatePLString,,
++ AC_MSG_ERROR([WUtil library not found]))
+
+ dnl Checks for PropList (not necessary since version 0.2.3b)
+ dnl AC_CHECK_HEADERS(proplist.h,, AC_MSG_WARN(Can't find PropList include-file: Please install libPropList (included in WindowMaker)))
+diff -Naur fsviewer-app-0.2.6.orig/defs/chdef.c fsviewer-app-0.2.6/defs/chdef.c
+--- fsviewer-app-0.2.6.orig/defs/chdef.c 2012-07-11 17:55:06.444981361 +0200
++++ fsviewer-app-0.2.6/defs/chdef.c 2012-07-11 17:55:50.387699640 +0200
+@@ -374,7 +374,7 @@
+ SetIntegerForKey(0, "DisplayMCListPixmap");
+
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+ result = 0;
+ }
+ else
+diff -Naur fsviewer-app-0.2.6.orig/src/extnInspector.c fsviewer-app-0.2.6/src/extnInspector.c
+--- fsviewer-app-0.2.6.orig/src/extnInspector.c 2012-07-11 17:55:06.452981130 +0200
++++ fsviewer-app-0.2.6/src/extnInspector.c 2012-07-11 17:56:02.315351669 +0200
+@@ -229,7 +229,7 @@
+
+ if(numRows > 0)
+ WMWritePropListToFile(filesDB,
+- wdefaultspathfordomain("FSViewer"), True);
++ wdefaultspathfordomain("FSViewer"));
+
+ if(extn)
+ free(extn);